Sequencer: Skeletal Animation Track Broken?

Greetings, after updating my project to 4.15 I’ve experienced a quite annoying bug in the level sequencer.
My exact problem is that animated skeletal Meshes started to flicker around like crazy and it seems like there is an error with the play speed of the animations. I have to speed up some of the animations used in the sequencer as they are authored at a much higher Framerate than 30. Animations that are running at normal speed are working almost normal for me, except some little flickers. I’ve set the animation speed in both the animation asset and the sequencer track as the sequencer ignores the set speeds of the assets (should stay this way as it is useful in some cases :D).
I have absolutely no idea what causes these flickers and I’ve already tried it without setting the animation speed in the asset viewer and keyframing the animation mode to animation asset instead of the new default in Sequences that gets calles “Custom”. That makes the animations work fine in non-simulating/playing viewports but as soon as I use Simulate or try to Render the movie the Meshes are frozen.

Any Solution for this?

Greetings RRe36

EDIT: Btw. What happened to the TAA, somehow it’s less effective after the update and tends to miss tiny specular highlights causing the bloom to flicker extremely and making DOF looking horrible due to that blown up tiny highlights.
I even switched to FXAA to get a more consistent result.

Anyone who has an idea of what could cause this?

Hey RRe36,

I’m having trouble reproducing this on my end. I’ve tried using 60fps anims since you’d mentioned a higher frame rate than 30 and cannot reproduce this issue.

Can you record this and show me what you’re seeing? Might help to send me an fbx file that reproduces this.

-Matt W.

Sure: Unreal Engine 4.15 Sequencer - Animation Bug - YouTube
Video is a bit older but that doesn’t really matters.
I’ve tested a bit and it seems like the Sequencer is taking the Play Speed Value set in the Animation Editor and multiplies this with the Animation Speed set in the Level Sequence. I don’t know if this should be this way but it’s nothing very useful. Because of this the Animations work with play Speed set to 1 in Persona but if you set the Play Speed to the Value you need in Persona and set it to 1 in Sequencer the flicker returns.
I’ll send you the Mesh and one of the animations as a PM using the forum (why does the anwerhub lacks a PM-Function or did I miss it? :D)

Any Update on this? Hope you’ve got my forum pm :slight_smile:

Hey RRe36,

Whatever you set the play speed to in the animation sequence now becomes its base playback speed. This allows you to use it throughout the engine without having to modify playback speed a second time. As a result, this sounds like expected behavior when you’re essentially modifying playback speed twice.

What software did you author these animations with? I brought your fbx file into Maya and it has frames essentially baked down every other frame when I have it set to 60 fps (indicating this animation is 30fps).

-Matt W.

These Animations where exported from a game and passed trough 3ds Max 2017 (until I have enough Time to rework/recreate/replace them) and basically these are 30fps animations that need the speed up to play at the desired speed. Now I can understand how I’ve triggered this bug because 5x in Persona and 5x in Sequencer gives 5^2=25x Speed :slight_smile:
I would assume that this one is solved unless I’ll find something related to this and if I do I will post it here but for now I’m mainly busy with getting deeper into Engine Source modifications.

I’m marking this as resolved. You’ll need to choose where is ideal for you to control playback speed. In the AnimSequence will affect every instance, but controlling it in sequencer gives you a little more control. In general, it’s best to ensure that your AnimSequence is playing at normal speed and then go from there. In the end, I would suggest authoring your final content at the correct play speed.