Sequencer not using camera cut camera.

Hello, I am having an issue with sequencer where the camera zeroes out and doesn’t move, regardless of the sequence and how the camera cut track is set up. In this example, I am using a cine camera attached to a rail that moves through the space. I am able to preview the sequence in the viewport and it works correctly. In addition, the sequence will render indefinitely and it never outputs an .avi file. I have created an empty project and repeated the same setup and the camera follows the rail correctly and outputs an .avi file as expected. Is there something I am missing or not taking into account? Thank you so much.

269288-preview.jpg

Does PIE work? Or just in editor scrubbing? If you just assign the camera cut to a keyframed camera, does that animate in game and in the render?

Thanks for the response. Currently, I can only visualize the cut when I lock my viewport camera to the camera cut and play it through the sequence editor. When I PIE, it only places the camera wherever I had it positioned in the editor and does not move. I have created a sequence with a camera keyed to pan 180 degrees. Unfortunately, it still suffers from the same issues as before: I can only preview it when played through the sequence editor, the camera zeroes out when rendering and no file is created in my output folder regardless of how long I wait. I repeated the same process again in a fresh project and it functioned correctly.

269368-preview2.jpg

Are you actually invoking the sequence to play in blueprints or have the sequence actor toggled to “AutoPlay”?

I have done it both ways–initially with AutoPlay to no avail, and then through blueprints–I can get the sequence to start through the the level blueprint, but the sequence will run indefinitely and no .avi will be output.

you have to be able to hit Pie then probably f8 to get control back to mouse and click the little camera icon on your camera layer .

if that doesnt work then there can be a multitude of issue that are messing you up .

there is a whole settings panel when you right click on the cut track - u have to make sure the camera is selected in there as well as it loses its connections for no reason

you can also try making a master sequence and putting your other sequence in there as this has worked for me when i just couldn’t figure out why my camera was flipping out and I have struggled with instances when I would get different results for Simulate - render to current window - and separate window

also when you make a camera SOMETIMES it creates it as spawnable which I usually uncheck and then right click on that camera and make it possesable - then make sure you always click SAVE on the actual timeline as somethings dont save properly when you just hit save in the editor which is really dumb.

But Sequencer when it renders goes into some version of Pie as it is rendering so if you can’t get that working then you got some issue . i would also try rendering to frames to see if they are working and its not just the avi render causing the issue

ok i got an idea and resolved this in your cinecamera setting , under scebe component - set mobility to > Movable. Thats the only thing keeping your camera from moving.

Check that your camera is in the right level and make sure it is not referenced in another level, If it is in another sub level, check to see if the sub level is set to always loaded. This might help get your camera reacting to sequencer again.

341437-sublevel-setting.png

Thank you. Actually just hitting simulate and then F8 fixed it for me. Sequencer automatically grabbed the camera at that point.