Download

Sequencer: Keep animations snapped to whole frames?

Hello,

Sorry if there’s already a discussion for this. I tried searching a few different phrases and couldn’t find anything.

My company is working on a game cinematic in the sequencer, where many modular animations are strung together to create the sequence. We have 10 different rigs with dozens of animations on each, and I have to drag them around a lot when my boss gives me notes.

The problem is I keep noticing gaps and overlaps where animation segments don’t snap together correctly, and when I zoom in to the individual frames I notice that they’re often snapping to timecodes in between frames. Lots of in and out points have ended up on frames like 1265*. This has led to rigs flickering between animations, or popping back to origin.

I’ve double checked my export and import frame rates and everything should be good. It seem like the sequencer just has an added level of “freedom” that I’d like to turn off.

Is there a way to keep things conformed to whole frame numbers the way Maya or After Effects do? Any other tips for keeping these clips tidy and transitioning smoothly?

Thanks as always!
Sean

Is snapping turned off perhaps?

Snapping.JPG