Sequencer is looping every time I enter level

How can I stop a sequencer from repeating itself all the time when you enter a specific level? I have a sequencer playing at the start (Begin Play) when you open the level, however I want it to play only once and never again, not repeat itself every time I enter the specific level. If I leave the level and then re-enter the level, it will play the sequencer again and I dont want that. I tried using the Do Once node but without any success.

You can set playback position in the level BP ( to the end ).

Hello Geo-GC,

I would recommend creating a boolean variable “SequenceHasPlayed”. Make sure the Default Value in the “Details” panel is unchecked (set to false). Create and plug a “!=” node into the condition section of a new “Branch” node. Ctrl+Drag the “SequenceHasPlayed” variable into the blueprint and hook it to the top half of the “!=” node. Mark the checkbox at the bottom of the “!=” node.

Hook the end of your Begin Play chain to the front of the Branch node. Hook your “Play Sequence” node to the end of the Branch. Alt+Drag your “SequenceHasPlayed” variable into the blueprint to create a “Set” node. Set the variable to True when you play the level for the first time.

This should keep your sequence from playing beyond the first time you enter the level.

Hey thanks for the detailed help. I am pretty sure I think I am doing something wrong tho since it’s a bit confusing.

If it’s not essential, I’d recommend triggering the sequence from a different blueprint. Fewer nodes that will be needed if you use an actor blueprint with a collision volume. Open up a new thread if run into any new issues.

-Andy S

To make this work across level transitions you will need to store the state somewhere (such a saved game) and then on BeginPlay check the saved state to see if it should play. I recommend disabling auto-play on the Level Sequence Actor (or skip creating it entirely!) and loading the saved game slot and checking the boolean before you create/play it.