Download

Sequencer : in game focal length different from preview focal.

Hello everybody !

I make my very first steps with sequencer and I’m very happy with it !
My first problem is this one : I use a cineCameraActor, linked to a cameraRig_rail.
I set the camera to zoom out and start with a focal of 50 and finish with a focal of 30.
When I preview my sequence in the sequence player, everything is fine but when I play the cinematic in game, my camera doesn’t use the focal length parameter set in sequencer but stay at 35.
While the cinematic is playing, I can see the focal parameter being modified in the sequencer player but at the moment I quit the game, the value of focal lentgth in the sequencer is set to 35 until I move the cursor.

Is there a setting anywhere I forgot ?
Do you have any idea to correct my setup ?

Do you have a camera cuts track to bind the camera to the viewport?

https://docs.unrealengine.com/latest/INT/Engine/Sequencer/HowTo/TracksCameraCut/

Yes, I do.

I’ve got a master sequence with a shot in it.
I put the camera cuts track in the sub-sequence.
Reading your message, I try to put another in the master sequence but it doesn’t solve my problem.

I’m actually looking at my other BP (the level one, maybe)… Perhaps is there something in it that set the focal length of my camera and would be the reason of the fact that my problem triggers only when I play the level and not in the previewer. But I can’t remember doing such a thing.

Edit : I use the “Quality Game Settings” menu that I bough in the market place. I’m pretty sure that the focal length setting in the video panel interferes with my manual setting. I don’t need it and I don’t even wish my players to have access to this setting. I will disable it when I have some time to inspect these BP I didn’t write myself and see if it solve my problem.

Edit 2 : Got it !
The camera modifier get the FoV value set in the menu. This value overrides the sequencer value.
I change it and everything is fine now :slight_smile:

cameraFOV_soluce.jpg

In fact, this chunk of code has no use at all anymore… I will simply remove it ^^.