Sequencer: How to use Full Frames only?

When working with the Sequencer I am having a difficult time to set keys at a FULL KEY FRAME.

Is there a way to change the settings, so that the Sequencer will only set keys at a Full Frame and not in between, half or third frames?

If I set a keyframe at Frame 200 - and I scrub through the timeline. you can scrub before the Keyframe 200 and even slighty after.
That means, additional keyframes are being recorded… slightly after or before the FULL KEYFRAME 200.

Is there no way to change the settings and tell the Sequencer only set keys on a Full Frame?

Do you have snapping enabled? That should snap the timeline to whole frames so when you set keys, they’re on whole frames.