Download

Sequencer drops Stepped/Limited Animation frames

Idk what the problem is, but it works fine in linear mode even without changing anything else as shown in the gif.
The moment I swap to Stepped animation mode, the sequencer occasionally drops frames or just doesn’t update them.
The animation editor gets it all perfectly though so I’m kinda confused on if this is a bug with the sequencer or some option isn’t on right.
I matched the frame rate to the same 24fps the animation is in because there was occasional teleporting judder issues at 48fps only for me to discover this.

I’ve included a gif to help show the problem.

if you throw your fbx clip, that the animation is on into maya, and it loads at 24 fps
if your UE import clip is on a sequencer track that is 24fps, it should line up

if you throw your fbx clip into maya and it loads at 30fps
then, there’s a discrepancy if your UE is 24fps

also it helps if the fbx you bring in is baked on every frame, as there’s no interpolation going on between frames if it’s set to the same fps

How interesting. Baking the entire animation seems to have worked for the earlier sectors but later on the dropped frames happen again, but I am seeing spaces in the bakes for some reason.
All the frame-rate stuff matches up though.
This might provide more insight to the problem when exporting from Blender as maybe there’s some other interpolation going on even after a bake that is screwing with how the sequencer, with stepped animation, reads it.

Edit: Yeah, I don’t get why the dropped frames move around each bake. I’m gonna chalk this up to a bug because the animation editor plays the animation perfectly in stepped mode while ONLY the sequencer doesn’t.

So i’ve found an update/workaround on this.
It turns out that stepped mode will mess up with any kind of time scaling differences. Like if I worked in 24fps and exported to UE4 for it to be used in sequencer at 48fps using stepped mode, it just messes up the 1-2 sequence of frames eventually.

I also tried exporting the baked animation at 48fps but forgot to change the keyframe distance. This one I had to slow down the animation by 0.5 in UE4 and the same issues popped up.

The way around this is to not use stepped mode at all because Linear works perfectly.
The way to do that is to animate in 24fps and then bake the keyframes along with visual data, (removing animation modifiers too) then set their interpolation to constant, then scale the keyframes across the dope sheet x2, (which is why the visual bake and removing modifiers early) THEN export at 48fps into UE4.
Linear picks up on this and now the animation has zero 1-1-2 and 1-2-2 mistakes randomly happening because of stepped mode.