Sequencer does not Pause/Play (long) Audio

This appears to be highly similar to a previously reported bug: Unreal Engine Issues and Bug Tracker (UE-25943)

Similar repro steps apply:

  1. Add a sequence, with an audio track, which targets a long wav file (~1 minute long)
  2. Call Play on the Sequence Player
  3. Call Pause or Stop on the Sequence Player

Using the Pause function on the Level Sequence Actor → Sequence Player (in blueprint) does not Pause the Audio.
In fact, I have just tested, and using the Stop function does not stop the audio either.

Setting the current position, and then calling Play, does play audio from that point onward (and it stops the audio if it was already playing).

I have attempted to manually store the Current Playback Position on a Pause, call Stop instead, set the Playback Position and call Play - but as the audio does not stop on a Stop call it is unusable (even though the audio resumes on a Play call from a given playback position).

As this is a moderately time critical project, what is my best option going forward?

  1. Split all of my audio into small chunks (time consuming, but doable).
  2. Use the Stop + store Playback Position method, and Play a Sequence with a silent Audio file to try and block the audio (pretty sure it won’t work, but I’ll test this now)
  3. Source code modification (happy to do it, if anyone can point me in the right direction).
  4. Any other workaround?

I found a solution that works!
Not sure why, but it may help with fixing the audio system. The trick is to Set Playback Position after calling Pause or Stop.

The Play/Pause/Stop functions previously just looked at my current cinematic (level sequence actor reference) and passed the call along (from the UI).

These new versions do so, but also re-do the Pause functionality and make the audio work correctly too!

Thanks, that worked for me as well. Note that setting the position to 0 might not be ideal on the stop. Some translations might get reset to the start that you actually wanted to leave where the sequence was stopped.