Sequencer Capture Animation Issue


I am having a problem with sequencer exports not looking the same as they do in the viewport.

My level consists of a car driving down a road with multiple camera angles. The car was simulated in 3D Max and imported as an FBX. The cameras have each been animated within their own sequencer and edited together within a master sequence. I am able to export the whole sequence out as a JPG sequence and everything seems fine. All animations and imported files are at 30fps.

The issue has only been noticed on cameras that are close to the car, but I am sure it is present in all. It seems to be the camera animation is either playing several frames too late or being translated differently to what is displayed in the viewport, some of the close shots go through the front of the car.

I have attached an image below to help explain. Top image is the viewport and desired result. Bottom is the export and incorrect. Both images are from the same frame number. Sorry for the ‘red out’ on the car, client is sensitive about the work.

Many thanks,

Things I have tried:

  • Pre-Rolling the animation - No change
  • Rendering individual sub sequences - No change
  • Fixed frame rate - No change
  • Making camera spawnable by sequencer - No change
  • Tried recreating camera and animation sequence - No change
  • Created a test project with simple objects and one camera - Viewport and export correct
  • Copying assets into a new level - No change

Things I have noticed:

  • Camera seems to be noticeably offset in the Y-axis.
  • Could it be due to fast moving cameras? At 30fps it is interpolating the between frames incorrectly?

Have you tried upgrading to 4.15? I believe there might have been an issue in 4.14 with Sequencer not setting up tick prerequisites correctly for objects that it controls. That might be the cause for the camera updating a bit behind.