Download

sequencer adding Particles not rendering the frames 4.24.3

Hi,

I’m having difficulties with my particle setup as its not rendering the output frames (jpg). I have created some shots, some times it does render out… other times
like this shot its not working at all. I can’t figure out why this happening. I have noticed that P_emitters you can turn them on/off by RenderingTab visible.
So lets say you don’t want them to appear you could turn it off.

Does anybody know why its working in the camera/cinematic mode, but when output the JPG frames the Particles won’t render. Or is this a bug perhaps?
Thanks in advanced.

Cheers
Decorix
ue 4.24.3


UPDATE


I have been testing some more.

I have noticed that when I dragg & drop a particle emitter into my scene/shot sequence from
the content browser into my shot. It then renders out correctly.

But when I have Particle_emitter which I duplicate from my Outliner and move this into
my shot it doens’t render show up in my export sequence (jpg).

Can a Particle_emitter be global?.. so lets say you have it in you’re shot (1)
but you also want it to be visible in shot (2)

For me this doesn’t work I think.

Would you need to dragg & drop a new Particle_emitter into shot 2 from the content browser.

Global heightfog is global so it effects the whole scene. But add to my Shot and can add the Fog components so this is adjustable.

Any feedback how it should work is welcome.

Thanks in advanced.

decorix

Try exporting in movie instead of jpg, maybe the export option is the culprit? or it could be the particle emitter that is the issue.
If you want to record two cameras at the same time, you probably need to do it twice. Each time for different camera and have it appended in an external video editor.
if you just want to switch camera, just add the 2nd camera “camera cuts” within the timeline in sequence. I dont have issue seeing multiple particles or similar particles(alt+Drag in scene) with switching cameras in 4.26.0p4. btw you need to trigger the emitter in sequence.

Just tried with 25.4, the particles seem to be a lot faster. While 26.0p4 is more well behaved(could be placebo effect). Do test with different versions, but do keep in mind that each versions have their own screw ups. Dont totally rely on one.

Hi PickersZ, Still struggeling with the particle scene…I have noticed that when I’m in my Rendermoviesettings and start to render out the frames… In my Outliner it turns on all the P_emitters. Is this normal?? I have only 3 selected P_emitters turned on with my eyeball which are visible… Any feedback on this? Thanks.

i could be wrong, the eyeball on the world outliner didnt do much to “deactivate” the particles or any effects for that matter. You will need to check “actor hidden in game” for the particles if you are not using them.

if you are using them but only want them at specific time in the timeline, “deactivate” them in the beginning of the particle toggle track and “trigger” them at the specific time of the particle toggle track. Particle toggle track can be found within the particle track that you have added to the sequencer.

If these failed, try using different particles in same version of unreal. Or same particles in different version of unreal for testing.

The ones that i was using were cascade based. So not sure if that made a difference. I have not ventured into niagara yet so cant help much in that aspect.

Hello PickersZ,

Thanks again for the great help. I have been reading up on things trying to understand whats going on. I’m using the particles of the UE Elemental demo such as P_snow, P_Blizard,etc.
They are appearing in my cinematic camera viewport only when I render they don’t turn up. What steps could I still check… ?

I tried scaling in the outliner that indeed that helped. When left 1.0 scale did’t see them. I also tried rotation hoping that might help…like facing the camera… it didnt…
I’m calling this my last call. Guess theres nothing wrong. Lookforward testing 4.26. Would like to hear from last time what I could check.

this is link I found:
https://answers.unrealengine.com/questions/210309/particles-are-not-visible-when-recording-movies-wi.html

i have just tried the demo but cant find the Particles that you have mentioned, so i used the P_Avalanche_filler_sphere and P_snow_boxes. They worked the same as other versions of the engine. I do need to uncheck auto activate in their detail panels though. Was using 4.24.2 unreal engine. Video or img seq capture worked fine in the render. Use a blank scene for test, it could be other factors that were causing it. Hope this helps.

Illustration.jpg

Thanks again. I think I got it wrong… they are from the Particle Effects pack (The cave demo from epic marketplace) I believe. auto activate only turns them on/off in the editor viewport. I tested with
rendering it didn’t help. I think to test it proper I need test on new 4.26 later on with a new project as I’m lost in this project 4.23.3. But thanks for all you’re help.