Sequence Player 'Play' Reset Bug

Whether ‘Restore State’ is set to true or false, telling the Sequence Player to ‘Play’ always resets once it ends.

This is occurring after converting my project from 4.14 to 4.15; it was working fine in 4.14. Not sure if this only happens with an existing player from 4.14 or if it happens with new ones created in 4.15 too (I will try to find reproduction steps later when I have time). I have read others are also having this issue.

Note that I am using the inherited Sequence Player in a blueprint class that derives from ‘LevelSequenceActor’.

This does not seem to be due to the 4.14 conversion; this is easily reproduced in a new 4.15 project with the following steps:

  • Create a ‘Level Sequence’.
  • Add a ‘Fade Track’ to the sequence.
  • Create a keyframe at the start of the sequence with a value of 0.0 for ‘Fade’.
  • Create a keyframe at the end of the sequence with a value of 1.0 for ‘Fade’.
  • Save the sequence.
  • Create a new Blueprint class with the parent class as ‘LevelSequenceActor’.
  • In the blueprint, under the ‘General’ section of the ‘Details’ pane, set the ‘Level Sequence’ field to the level sequence we created.
  • In the blueprint’s Event Graph get the blueprint’s ‘Sequence Player’ on ‘BeginPlay’ and call ‘Play’ on the sequence player.
  • Drag the blueprint into the level/map.
  • Press play on the map and observe it resetting the sequence to a play position of zero once it finishes fading, where the scene will be transparent again at the end (instead of black) no matter what ‘Restore State’ is set to on the blueprint.

Here is a link to a new 4.15 project that follows these reproduction steps -

Hey ,

Can I ask what your intended functionality is? If it is fading out of a cinematic and back into gameplay, I’d highly suggest using separate fade in/fade out sequences and triggering the fade in at the end of the fade out or a frame before the end.

The other way is to manipulate the player camera’s Gain Alpha Channel. When a cinematic begins, set your player camera gain alpha to 0, then create your cinematic with the fade to black. When the cinematic ends, you can trigger the gain alpha to fade from 0 to 1 in your blueprint.

Generally, we avoid using the level sequence actor as a parent class for a BP since we recently introduced Sequencer Components.

Let me know if any of that helps. If not, we can go from there. I suspect the behavior you were seeing in 4.14 was actually a bug. Since the fade track is not tied to a specific camera, it would become problematic if we let it persist after the sequence had completed.


I use it for dynamic cinematic events in my project that might also blend with things such as fading the camera in/out on death/respawn and when the camera goes out of bounds.
For those reasons, using separate fade in/out sequences means in a dynamic situation more than one could play or cause overlap (or start at different fade times in the case I want to stop one but continue on with the new fade from the fade percentage the last one was stopped at); I can setup a work-around to ensure one doesn’t play over the other and to adjust accordingly, etc, but it is simpler and much tidier to use one sequence.

I do not believe it was a bug in 4.14 as it is also noted, in the following link, by Max.Chen that in 4.15 it has been corrected so that it does not restore by default, with the option of manually controlling this with the addition of ‘Restore State’ - How can I stop a Level Sequence from resetting at the end ? - Cinematics & Media - Epic Developer Community Forums.

I chose sequences as they were the most recommended approach for fading scenes in UE4 (and the PlayerCameraManager’s fade functionality does not affect widget rendering).
I parented Level Sequence Actor as it appeared to be the main way of dynamically using sequences in 4.14 and I wanted custom functionality encapsulated in the owning Blueprint.
As sequences still seem to be a work in progress, with Sequence Components being newly added to 4.15 for early adopters, I’ll try a post-process or UI overlay approach for fading for now (if you can recommend something simpler/intended for what I desire, that would be appreciated).

I don’t have any experience with cinematic content so forgive my ignorance but I don’t understand the last part where a fade track optionally persisting would be problematic (unless you mean with the use of the new components; though, wouldn’t that be controllable functionality from the components to achieve desired results anyway?).

Thanks for the information and suggestions.

Hey ,

I’m going to suggest that the other issue at hand is different than yours. Your issue appears specific to the fade track. If I add a translating cube to your sequence and play it again the cube will remain at its end position.

I’m going to continue investigating this AND the other issue, but I’ll be noting in the other thread that I may still need some examples from the other users who are seeing this with tracks other than the fade track.

I’ll let you know when I get back to this issue as I have a few others that require my attention first.

Thank you for your patience.

Ah okay, I hadn’t realised this was just with the fade track; that definitely would make it different as it then sounds like a fade track issue rather than a sequence/sequence player issue.

Will wait to hear back from you, thanks for your time.

Hey ,

I’ve entered UE-43313 for this issue. I’ve included some of your use cases. This functionality still may not change because of the impact it could have if your game becomes stuck faded to black.

Great to hear, thanks. Still not following the issue of it remaining black as it should be as simple as telling it to set playback time to zero or using ‘Restore State’ to avoid that, if remaining black is not desired.

If you return back to gameplay and want all objects in your sequence to remain in place, but you have a fade to black track, then the screen gets stuck on black. That’s the problem.

Ah ok, when everything is in the same sequence, that makes sense. I was only thinking it would be used in an independent sequence; I can understand why this is a problem then. Sorry, I haven’t really used the sequence for much else so thank you for explaining that politely.

Hey ,

Just a heads up, there were some fixes put in around the fade track based on this bug report, but it was not a bug as we had originally thought. If you right click in the fade track>Properties>When Finished and change it to Keep State, you should be able to get the functionality you’re looking for. I had no idea the fade track defaulted to Reset State.


That is great news.

When you say to right click in the fade track, is that within the Sequencer? I don’t get a ‘Properties’ option when right-clicking the fade track in the Sequencer and can’t see anything under the Sequencer options.

You’ll need to right-click the track in the timeline section. See below.

Ah it wasn’t doing anything for me when I tried that. Turns out if you right-click in the timeline then right-click on a track it doesn’t do anything (I assume it deselects the track and doesn’t re-select from right-clicking on it; made more confusing if you left-clicked the track beforehand as it still shows the selected orange effect after right-clicking a blank space in the timeline).

Thanks for that, it’s back to working how I had it in 4.14.

Is there a way to make keep state the default instead of restore state?

I answered it here. But you need to split the blueprint sequence player settings and set the option in there

I believe that this might help, though this is 3 years ago, just stumbled upon this.

I believe that this might help, though this is 3 years ago, just stumbled upon this.

It’s not a bug, you are just using the wrong variable to achieve the effect you want!
You just need have to have ‘Pause at end’ checked.
(Even with Reset enabled, it does not change the Pause at end behaviour)