Self object Reference is not compatible with object reference

So I’ve recently updated my project from 4.21 to 4.22.2. Since then I’ve had a host of problems. I’ve not been able to sync/pull from source control the engine will just crash. After look through this crash log InsertNameV2.log - Google Drive and reloading assets in the editor I’ve seen this error pop up Self Object Reference is not compatible with [bp name here] Object Reference.
Here is a example

Now in the output lot it says this

Am getting this error across many different blueprints using the self reference node. So are there other nodes I can use to get an instance of a blueprint? Or am just doing something wrong here?

I don’t think the screenshot is related to the error message. It sounds like an orphaned pin on something else. You should look for a node / function / event (ctr+f in MasterSpell BP) called Casted Spell. It’s very likely its pins are connected with red wire, right clicking and refreshing the node should solve it.

I’m assuming there’s more than one instance of this. Or is this the only place that ‘Casted Spell’ is referenced?

this only place where casted spell is and that was just a general example am getting this same error across my project and I’ve been looking through and I haven’t red wires or anything.

I’ve noticed sometimes it bugs out and I had to rewrite the blueprint code and it worked again from scratch and connect the pins manually. Don’t copy/paste. (For me it bugged without showing any red lines.) Try this maybe it will help.

So I’ve tried rewritten a bunch of code and am still getting those errors so seems something else has bugged out

What blueprint contains that set of nodes??

so this specif blueprint is my master spell blueprint which hold’s a bunch of my custom functions for spells

tho I would to add am getting the same problems across most of my blueprints

Can you post screen shots of where you pass these variables through to the player character? Also are you absolutely sure there is no other place where you call anything from the “master spell” class from within a “master spell” or child of a master spell blueprint?

Ya here are some some screenshots and ya am sure no other place and and really the master spell that’s causing most the errors and blueprints not even related to the master spell in any way that getting this same error

Sorry, I don’t understand that last bit…what do you mean it isn’t related?

here is example am getting this exact same error in a different blueprint that doesn’t even reference the master spell

The only common factor I’ve seen between all of these blueprints is am using self as a target. So I just disconnect self from all my nodes in my master spell and my errors went away. So my conclusion here is that the self node itself is kinda jacked.

Well that’s odd haha don’t know what to tell you

Is alternative node I can use to self? All I need is to get a instance of a blueprint.

Have you tried “get all actors of class” on begin play and get a reference from there?


Also make sure to test for “is valid” before throwing around references. So that the BP that needs the reference actually gets a valid one, otherwise it’s just NULL when the requested BP is referenced too early or failed entirely

What is class of this blueprint and what type is the function input? Can you make screen shot of a class tree to blueprint (Window->Devlopment Tools->Class Viewer)

That’s actually a pretty good Idea but how would get the specif instance of the blueprint tho?

Alright here is a screen shot of class viewer

Just a note the player character is seems to be affect

ok whats the type of input pin of your function End Cast and so on?