Selectiong 8kx8k heightmap to impot landscapes slows editor

Just selected an 8161x8161 heightmap to import to landscape and unreal engine slows like a hell.

Empty project, opened landscape tab, selected heightmap to load form file - and that it.

How much ram does your PC have and how much is UE4 using in this situation?

Does the performance issue go away once you press “Import”?

It may just be that your PC isn’t capable of handling such a large heightmap.

My PC have 32GB of ram, UE uses 1,2GB. UE uses around 20% of CPU, but reacts very slow to anything.
Importing takes some time… and UE uses from 2GB to 4GB
After import all works like a charm.

Maybe that those stupide Xeon CPUs.
I have CPU

Intel(R) Xeon(R) CPU E5-2603 v3 @ 1.60GHz

Maximum speed:	1.60 GHz
Sockets:	1
Cores:	6
Logical processors:	6
Virtualization:	Enabled
L1 cache:	384 KB
L2 cache:	1.5 MB
L3 cache:	15.0 MB

Utilization	54%
Speed	1.58 GHz
Up time	8:00:15:58
Processes	121
Threads	2254
Handles	919146

Performance drops considerably at 2048x2048 heightmap, i got 3FP in editor.
After import 110FPS

GeForce Titan, drivers 372.90. Will update them and report if something changed.

Create works without lags. But green mesh looks different from Import mode. It is more dense in create.

How’s performance on “create” mode vs “import”? If it is better, that indicates an issue with the way the import data is being used for rendering.

Also, what’s your graphics card?

Ok, definitely not a PC issue then.

Hi ,

I was able to reproduce this on my end and have entered a bug report, which can be viewed here. You can track the report’s status as the issue is reviewed by our development staff.