Select node causes crash on HTML5 (on load)

Using a “Select” node in a blueprint causes crash during load on HTML5 (tried in both 4.9.3 or 4.10 preview 4).

To reproduce, drop a blank actor with a select node in it (one [attached][2] for your convenience), into Entry.umap (or a copy of Entry.umap) and launch from editor to HTML5.

The “Select Color” or “Select Int” nodes appear to work fine (but they don’t allow you to add more option pins, which I need in my case).

This is the cause of a [previous question][3] I posted, just reporting as a proper bug now.


The Select node does allow you to add additional options to it, if you right click on the node. I’m currently in the release of 4.10.0 while attempting this. I launched my project where I added in the actor that you provided and I did not experience a crash. Do you have the or any screenshots of the error that was produced when the project crashed?

Looking forward to hearing back from you, thanks.

I can confirm this issue in release 4.10.0 (I didn’t tryed the actor but I ran into this problem myself and needed to replace all my switch notes with switch int or brances)

This is whats get printed into the console Expression 'ExportMap.IsValidIndex( Index.ToExport() )' failed in D:\BuildFarm\b - It works on all other platforms (all I tested…)

Hi Sam,

Here are the most basic steps for reproducing in a fresh 4.10.0 (same as above but with more detail):

  • Create blank project (settings: no starter content, scalable 2d/3d, mobile/tablet) - I named it “Blank4_10”. Open the project.
  • Open the entry map from the engine folder, save a copy in content folder as MyEntry.
  • Create a blueprint based off Actor, and on BeginPlay add a print string with a select node being used to determine the input (as in my above pic). It has to be a generic “Select” (wildcard) node, not “Select Int” or “Select String” etc.
  • Drop the actor in the level, save, run on HTML5 via the launch button.
    In firefox, the browser will load and show the “Compiling” message for a few seconds before crashing with the [attached][1] output. In Chrome, it will just hang during loading and become unresponsive. On all other platforms it runs fine.

I think you might’ve misread the original post about adding pins - the Select node does indeed allow extra pins to be added (which is why I’ve been using it), but that is the node that is causing the crash - the other non-generic select nodes (which don’t allow extra pins to be added), do not cause a crash.

I’m basically in the same boat as MiniDigger - replaced all my generic “Select” nodes throughout my project (about ~30 or so) with their non-generic equivalents where possible, otherwise using “switch int” nodes or branching. Now it runs on HTML5 no problem.


66892-selectnodecrash_firefox.txt (12 KB)

The select node doesn’t allow me to save it unless I attach something to Option 0, Option 1 and the Index Wildcard. So I’m not sure how you’re getting passed that part? I continue to receive errors. Could you include a sample project, or the sample blueprint that’s set up correctly?


Hi Sam,

The node allows you to enter literals once it knows what type to expect (i.e. if you plug in the output first), or you can use a “Make Literal Int” node. However it’s best to just make an Integer variable and hook that up (if you only use literals, it seems like the compiler detects that the Select node is redundant and gets rid of it, so it won’t crash in that case).

The [TestActor linked in the first post][1] is still a working example, if you use that along with the instructions in the previous post. Pretty much any usage of a select node should cause the crash. Here’s another example that does:


Thank you for clarifying this issue. I have verified this occurring on HTML5 and have entered a bug in , which can be referenced as UE-23816. Please feel free to reply back if you’d like to check on the progress of this bug.