Download

Seemingly cryptic problem I cannot give a proper title for

It all started when I was trying to change the engine’s (the one that launches when you run a map) renderer to OpenGL, so I set the editor viewport to Shader Model 4 (the one with OGL 3), so I would force the shaders for that specific Shader Model to compile (a bit unnessecery but worth a shot?), and then I ran the level, but then i ran into some errors that I forgot what they said that prevented the engine from further running, so i decided to google my problem, came up somewhat inconclusive, so I decided to upgrade to 4.12. Then after that, i ran into another problem that said it cant find UE4Game.pdb. I googled that, and it suggested that i install the debug symbols, but I’m running out of space on my internal hard drive, so i moved the EGL to my external 1TB drive, let it repair itself, and then installed the debug symbols. But then when I tried to run the map again, I ran into ANOTHER problem. Sometimes when I launch it Windows gets completely unstable to the point where I have to do a forced shutdown (which isnt good for mechanical HDs), but some times windows lags alot and then the output console eventually says something completly nonsensical that is something like “UE4Game:so:and:so: Fatal error!” (and then it says “LOAD FAILED!”). My only guess is it’s trying to load the debug symbols, but can’t because I only have 4 GB of RAM ouch :(. If I can disable it trying to load the debug symbols, I will probally be able to get further with this. So please help.

My guess it’s a combination of trying to change the install paths (try removing the install completely and downloading from scratch) and trying OpenGL which I’m thinking isn’t fully supported, and also if you only have 4GB of RAM then your system might be unsupported in terms of hardware power.

I will try that see if it helps at all, but keep in mind everything ran fine before all of this partial-understood nonsense happened.

You don’t have enough RAM. I am running 10gb of RAM and I have heavy lag and occasional windows error messages. You need at least 8gb, at the very least.
It should be noted that I use 2 monitors and there are other factors in play but 8gb is min.

Would freeing up the RAM by terminating any open background processes work, or should I go back to 4.11 and go from there?
(Also, I’ve been waiting to reply for about a week now because of the unexpected maintenance.)
(And I know 4.11 worked before.)

I highly recommend using the latest version of UE if possible for several reasons. About your other issues all I can really suggest is buying more RAM. I know it sux but you need at least 8gb min to run UE proper.
I assume you’ve tried but if not verify your Engine files: UnrealEngine>Library>CurrentVersion>Verify. Good luck.
(Maybe upload pc specs if you have time, thx.)

  • What are Unreal Engine 4’s system requirements? *
    “For developing with UE4, we recommend a desktop PC with Windows 7 64-bit or a Mac with Mac OS X 10.9.2 or later, 8 GB RAM and a quad-core Intel or AMD processor, and a DX11 compatible video card. UE4 will run on desktops and laptops below these recommendations, but performance may be limited.”

Unreal Engine FAQ

I have managed to revert both the map and engine back to 4.11, and the engine launches and deploys without error. I still however cannot switch the engine’s renderer to OpenGL.
EDIT: Now I’m back at “Failed to find shader map for default material WorldGridMaterial! Please make sure cooking was successful.”
I disabled Mobile HDR and it still says it.

Should I just give up trying to mess with the renderer settings?