Seem to be having a casting issue

I’m attempting to have an item equipped on the player via a socket, i think it may be an issue with the way I am attempting to attach a specific item through the cast as I am referencing the master item blueprint (which the item in question is a child of) unreal doesn’t throw any errors, however it will not equip an item to the socket. Kinda scratching my head on this one pretty hard, any advice would be greatly appreciated. Let me know if you need any further screen shots. Thanks in advance.

you need to cast the player character first, then you can get the mesh from it. however i prefer to do the attaching on the construct (that way you can see if its properly attached too) and ingame just change the static mesh value of the weapon or w/e you are using. remember, if you dont cast, you only have access to the parent class, if you want variables inside your own made BP class, you have to cast.

I’ve tried what you’ve suggested and it’s still doing nothing. I’m referencing a static mesh in a parent blueprint to equip a mesh from a child blueprint. This action is being called from a custom event in the parent item blueprint. Is it because it’s not part of the construction script in the actual player blueprint? if so how would you get the proper cast from an actor event?

have you tried the attach node on the construct of the character? does it shows it properly attached? also if what you want is to show a weapon or item on the slot, you should just attach it since the beginning and assign the static mesh upon equip, or add a child actor, attach it on the character blueprint on construct and set the class on event.

I realized part of my problem was i didn’t have a skeletal mesh set on the character bp itself. setting it by default doesn’t seem to be an issue at this point but calling it from a custom event is still not working

You helped me immensely

buddy and i appreciate it, i think all i have left at this point is to properly reference the master BP so i can use different weapons but here’s a screenshot of the code fix called from an inventory button. Thanks big time.