Second add to viewport Widget is invisible

Hi !

I have a problem with my widgets. fast review : I set widget to be created once at the “begin play” from my level blueprint. Then i add to viewport when i need them & remove from parent when i don’t need them. But, the second time i add it to the viewport buttons & images are invisible but still works… like if i don’t move my mouse around & i click it does the click event.
I tried to set visibility to hidden or even collapse instead of it does change nothing. At first i tried to hide 2/3 buttons but even the third was hidden (click event still works). Then i tried without changing any parameters they were all visible and clickable.
Now i tried some tweak and it is as i first said, they are all invisible even if i set visibility to visible…

Any ideas ? :frowning:

PS : The way it works : Widget 1 + Widget 2 on sides → click middle button … hide widgets, camera changes … → Widget 3 → Click middle button … hide widget, camera changes … → Widget 1 (should be visible & clickable, i only got clickable)

PSS : If i don’t remove the Widget 1 from parent when the Widget 3 is added i have a warning that says this widget is already on viewport… the ■■■■ ? maybe names are too long and UE can’t read until the end ? (Widget 3 is a Dupplicate from Widget 1 with some modifications)

Same problem here, I tried to do this, or create a new canvas panel, add my widgets and then clear the children, any function possible to remove the widgets.
link text
So yes, it removes the widgets, but when I try to add a child to canvas, it doesn’t add it.
link text

@Digipoulpy, can you share your blueprints? I’ve seemed to fix my issue by just testing the UMG itself, so remove from parrent and then add child to canvas works for me, the problem was at the logic that destroyed or spawned them, so UMG works fine in my case

Don’t judge me, it’s quite ugly ^^

If you can’t properly see i’ll zoom-in a bit better, my screen is a bit small so i can’t take large screenshot…

EDIT : I kind of see that i wrote some stupid ■■■■… i changed the way my widgets work. It is more like only 2 widgets and not 3 with some buttons call for character at first & after the second widget it change as a “start game”. But it is still a fail, like it hides everything even if i try to force set visibility. I can still click where the button should be and it works, but i said, can’t see it.
Hope you understand what i try to explain >.<’