"SDK v8.1 must be installed", even tho it already is


I’m using Unreal Engine 4.15.1 on Windows 10 (64 bit)

Every time I try to open a"Basic Code" it says the same error.
" Running D:/Program Files (x86)/Unreal Engine/UE_4.15/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“D:/Program Files (x86)/Unreal projects/MyProject2/MyProject2.uproject” -game -rocket -progress
Discovering modules, targets and source code for project…
ERROR: Windows SDK v8.1 must be installed in order to build this target."

I already installed and restarted my pc after the installation of SDK which I downloaded through this link: Windows SDK - Windows app development

I even reinstalled Unreal Engine 4.15.1 but it still doesn’t work.
Every time I try to open a basic code it says the same error.
I can normally open a “Blank Blueprint” though…

Thank you in advance.

GenerateProjectFiles.bat not found Windows SDK 8.1 - Programming & Scripting - Unreal Engine Forums this helped me when I was having a similar issue.

you might have to add following path “C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit” under environmental variables

Thank you for trying to help, I did everything as the Staff member said in the link you provided but it doesn’t seem to work.

When I open “Environmental variables” there are “System variables” and “User variables” - both had “Path” in them. The “System variables” already had the path written in them, but the “User variables” didn’t so I’ve added it but it doesn’t seem to work.

One thing I’ve noticed though is that the path, under the “System variables” was automatically set to:
“C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit” but when I check for the folder location I can’t find it.

Here’s a picture of how it looks: http://prntscr.com/exs6s7
(I already have enabled the option to see hidden files)

I hope this information will be helpful.

Hello DreaMzZyyy,

Usually when the SDK isn’t being recognized, the best method to fix it is to uninstall the SDK itself, restart your computer to ensure that the uninstall is completed and then reinstall from Microsoft’s website. I would suggest doing this for both the 8.1 and 10 SDKs.

Edit: Keep in mind, while the SDKs are numbered, the Windows 10 SDK is not an upgrade for the Windows 8.1 SDK and it’s best to have both installed.

Hi Matthew,
Thank you for your help, I did a “recovery” with my system about a week before I installed SDK just to be sure I got rid of it and now I installed it back.
Everything works now, thank you.


you can download it in VS installation: