Download

SDK error when uploading ipa to appstore

Hi all.

I’ve tried so many methods to upload an ipa to the appstore using Transporter but I always get the same error: ERROR ITMS-90725: “SDK Version Issue. This app was built with the iOS 13.2 SDK. All iOS apps submitted to the App Store must be built with the iOS 14 SDK or later, included in Xcode 12 or later.”

I created the provision and the certificate with no errors, all made from a Mac in a cloud service. I have xCode 12.5.1 installed. I’ve packaged my unreal project using originally unreal version 4.23, then tried 4.26 and the latest 4.27 preview 2 both with the minimum iOS version pointing to 14.0 but everytime I get the same SDK version error when uploading to the appstore using Transporter.

Is there something I’m missing or doing wrong? Anyone knows what workaround should I try or could point me in the right direction for uploading to the appstore?

Hope someone can help.

Thank you.

SDK error


os version

1 Like

The same for me.
He’s compiling with xcode:

Do you had a look to setting up AutoSDK? In that way you should be able to reference lastest sdk from Apple.
I’m on it right now.

Thanks for the reply akufene.

I found a way to make it work. What I did was create a completely new C++ project in version 4.26 in the Mac so xCode could compile it, then I replaced the Content folder from my previous project to the new created project and then after packaging the app use transporter to upload to the appstore and worked as expected.

Thanks a lot for this. That transporter error was very annoying.

Can confirm after creating a C++ project and replacing content folder, Transporter accepted the build and uploaded the IPA. I wonder when will Epic or Apple fix this. Can still be tricky on a Mac.

I built my game on a Windows computer and using my friend’s MAC to upload the game using Transporter. I’ll try what you suggested and see if it works for a Windows computer.