Download

SDI VIDEO INPUT via MediaBundle freezes

We do a lot of virtual production and we would really like to testdrive UE5 for some simpler composure comps because of the better lighting, performance etc. with UE5.
We got every plugin in beta for the UE5 we need to accomplish great results but unfortunately the MEDIA_BUNDLE is not working properly.

We are using a Decklink 8K Pro - the SDI-IN is a stable FullHD Video. If we than drag&drop the MediaBundle somewhere in the scene, it stops playing afer 10 seconds, somtimes after 2 minutes and sometimes if we click somewhere in the UE window.
We tried different PCs with different Decklinks - we always got the trouble, that the SDI-Input-Video stops playing after a random amount of seconds or after we do some actions in the gui.

If you like to debug and recreate this bug:
To speed up the effect, so that the video stops earlier, than try to use 2 MediaBundles with 2 different Video-Inputs via SDI. One or both of the Videos freezes after a certain time.

Is this a Plugin-Problem of the Blackmagic/UE5-Plugin or is this a UE5 Problem?

We can run 4 different 4K Videos with 4 different MediaBundles without such freezes in UE 4.27.1.

Please check this one - otherwise UE5 is currently not suitable for virtual productions with live video-inputs via SDI.

PS: We use the 1st SDI-IN for the Color-In of a green-screen live recording and the 2nd SDI-IN
is the ultrafine matte coming from an ultimatte live-keyer.
Either the ColorIN stops playing or the MatteIN. :frowning:

Hi @JerryDOCK11,
You may find you need an upgrade to your PC.
The minimum spec is
8 GB of VM, and 32 GB of RAM. 12-core CPU at 3.4 GHz for 30 frames per second, Nvidia RTX 2080 or AMD Radeon 5700 XT, and 64 GB of RAM are estimate

The PC which will run 4.27 will not usually run UE5
you MUST have an 0.5GB SSD/NVRAM boot drive to stand any chance of using the UE5-release. This is more critical than a super RTX graphics card.

To test your system which is used by UE5 after building the UE5.0-main
see Visual Studio 2022 RC 2 builds and runs UE5.0
This is the UE5 repository I built the test with
and download and convert
In-Camera VFX Production Test | Unreal Engine Documentation
and the project will convert build the project and run it.

If you cannot complete this on your current PC may need an update/replacing and it’s the test Epic used to test UE5. I added a 64GB page file.
This is just my opinion but I have built and used the * Virtual Studio learning example easily, but In-Camera VFX Production Test took a long while to get working.
Binary 5.0 EA2 may not work and that’s why you need to build the source.

Thanks, Jimbo

Hey Jimbo,

I dont think that our hardware is too weak.

Here are some specs:
-AMD Ryzen Threadripper PRO 3975WX 4.2Ghz sWRX8 144MB
-DDR4 64GB PC 3600 CL18 Kingston KIT (2x32GB) FURY Beast RG x 2 = 128GB
-MSI nVidia RTX3090 Ventus 3X OC 24GB DDR6, HDMI / 3xDP
-Blackmagic DeckLink 8K Pro
-SSD Samsung 980 Pro MZ-V8P1T0BW 1,0TB M.2 Typ 2280 PCIe

Any other hints - what might be the reason?

Hi @JerryDOCK11,
I have tried to load the plugin from Marketplace and the 5.0 EA2 as the Document Blackmagic Video I/O Quick Start | Unreal Engine Documentation

says and I have tried to load. I cannot find a UE5 specific version anywhere and the latest version is supposed to be in 4.27.

(GitHub - ue4plugins/BlackmagicMedia: The Blackmagic Media plugin enables users to natively send SDI video in and out of Unreal Engine.) This is version 1 and supports UE4.24

These drivers come from 4.27 they are all Version 2.0 and as with many plugins they have not been tailored for UE5.0.

In the very latest leading-edge which I have in my archive contains the driver jimshalo10/UnrealEngine-5: Update the Quixel Plugin to the latest version 2012.0.04. The original Early Access 2 branch for VS2022 is “ue5EA-vs2022” (github.com)

I assume as a company you want a stable release, well this was sort of stable on 30th October, but later releases are more unstable, they won’t build! sometimes.
Your PC Spec seems to meet the requirements
I really don’t know what to say its a moving target! with UE5 and the only official version is 4.27