Scrollbox not scrollable

Hi guys,

I have a scrollbar inside a canvas panel but the scrollbar is not working. I tried putting it in a horizontal box - the result is the same.

Also, there are some buttons in the scrollbox added dynamically which are not clickable.

Does anyone have an idea what the reason might be?

Here are the pics:

Thank you!


I just tried setting up a scrollbox and noticed that the scroll bar doesn’t show unless there are enough items in the list to overflow the scrollbox size. Do you have enough items in your list that a scrollbox is needed? I found that even though you check on the “always show scrollbar” option it doesn’t appear to work. My scrollbar doesn’t show unless there are lots of items so that the scrollbar height is exceeded.



quality, thanks for your reply. The scrollbar shows, the problem is that it can’t be scrolled.

have you enabled mouse inputs?

Yes, the mouse cursor shows. I’m wondering if it has something to do with the Add Child node - not adding children correctly?

I knew Super old thread, but there was never an anwser. Okay I just wanted to put my two cents in here. :slight_smile: I just had this issue and come to find out that the other items in the widget in order were set to visible and everything in front of that part of the widget (borders, boxes, etc) needed to be set to Hit Test Invisible or Self Hit Test Invisible. Once doing this it worked! I was able to scroll. Even the root itself had to be Self Hit Test Invisible

this is very old thread… but let me tell you solution, just increase the ZOrder value of ScrollBox to 1 so you can actually access on ScrollBox over other things

Hi, all necroposters. I got the same problem today.
A scrollbox is created in billions of kilometers tall, and its low edge is not visible beyond the edge of the screen. Therefore, all objects fit and the scroll does not work. Just add sizeBox and put scrollBox in it. in sizebox, set a limit on the maximum height.


Not all heroes wear capes. Thank you kind sir!

My solution is to use fill: