Download

Screen tearing when running in DX11

When I add -DX11 to the command line when running my game, it goes in in DX11.

Performance is totally fine, but I get crazy screen tearing. Even though I have v-sync on.

Anyone else have the same problem?

First, a disclaimer: I don’t know how well UE3/UDK works in DX11. I’ve run into bugs with it, and someone around here always used to mention UDK in DX11 blowing up his video card.

With that out of the way, have you tried unlocking the fps in \Config[your game]Engine.ini? Look for these lines:



bSmoothFrameRate=TRUE
MinSmoothedFrameRate=22
MaxSmoothedFrameRate=62


And try disabling smooth frame rate or set max frame rate to something much higher. See if that helps.

Yeah i tried that, but it doesn’t seem to affect anything with this tearing.

Is the screen tear look like horizontal off frequency? if so v_sync wont effect it.

I don’t use dx11, but the times I tried it I noticed that vsync didn’t work (when it did in dx9).

Give the max smoothed framerate a value of 120 and see if that fixes it(it does for me on a 4k 60hz monitor but still not 100 % perfect ,but close).Is your monitor 60hz ?

Nah, I have a key to cycle the maxsmooth, 30, 60, 300… vsync didn’t worked. Probably there is some other option in the ini’s.

Huh, this is kind of a blocker to using DX11 in UDK. I imagine this is fixable in UDK, as there are plenty of UE3 games that utilize DX11 without this issue.

that’s me. tessellation by distance doesn’t have a maximum tessellation clamp value and I had a true first person view, so it made my GPU overheat. it didn’t physically explode but since then it showed damaged blocks of pixels and distorted colors after 2 mins of turning the PC on.