Screen-Shaking Issue When Using Matinee [Repro]

Closing Matinee without un-toggling the Director track preview leaves you with a shaking viewport.

To Reproduce:

  1. Create or Open a Matinee sequence that has a director track, and maybe just to be safe, a couple of camera tracks too.

  2. Click the yellow camera button to force the viewport to show the current director-track matinee frame

  3. Close matinee, your viewport should start shaking (its contents that is)

  4. Re-Open matinee, click the yellow camera on and then off again, then close matinee.

  5. The shaking should stop.

No idea what causes this, I guess Matinee doesn’t let go of the camera when you close it and the viewport and matinee commands are conflicting?

Hi Jamsh,

I was able to reproduce this and have entered a bug report. Thank you for letting us know!

Awesome, thanks :slight_smile:

I had this too and came to look - glad to see it’s on record and being looked into :slight_smile:

Just an update, this still occurs in 4.2.1

This still occurs in 4.10

Hi michaeleeli,

Thank you for this information, we will take note of this for sequencer.

I’m still getting this problem in Sequencer in 4.12

Hi MattMerrill,

This error is from a significantly older version of the editor. Additionally, Sequencer has replaced matinee. Because you are experiencing this error in Sequencer, it would be best to open a new answerhub post. In your post, please include what steps you are taking to reproduce this error on your end along with whether or not this occurs in a clean, blank project with no additional content or if it is limited to one project. I am closing this thread as outdated.

Hi all just an update, I’m still getting this problem in 4.13 with Matinee at least.

above says he’s having the issue in Sequencer as well, though I haven’t tried it to confirm that yet.

Hi ,

Sequencer is intended to be a replacement for Matinee. Can you check to see if this error occurs in Sequencer for you? If so, are the steps to reproduce the error the same as above?

Using 4.13 and also having the issue. In my case the bug seems also connected to general quality setting - the shake occurs when antialiasing is temporarily turned off - the engine scalability settings have no influence on this.

I haven’t been able to reproduce this on my end in 4.13. Do you have any steps I can take to recreate this on my end?

Hi , . To be honest, I wouldn’t know what exactly made the difference. It’s a scene that came from last year and I did a couple of cinematic cameras to conclude the project. At certain points in the playback of the sequence the quality pops to a bad quality. Recording or not. I have been rendering several animations before and this was never the issue …

I also have been looking at Framerate and it stays well around 100 to 120 FPS. Additionally the whole phenomena is not dependent on resolution - even in small resolutions the issue occurs.

If you want I can render out some short clips for demonstration. Would that help? As said the main aspects are the shaky camera and the loss of Antialiasing …

The clips or a repro project may help me to see what you are seeing on your end. I’ve tried but thus far have been unsuccessful in reproducing this error.

Hi Ada. Thanks for looking into this.
Here is a short movie, showing the issue:

Btw, when scrubbing through the sequence in the editor, everything is just fine. It’s only when I “play” or render out a movie. I will see if I cann simmer down the issue but I amm not sure if I manage.


What post process settings are you using? Do you have it set up in a global or per camera? It looks like the temporal AA is not being applied to the tonemapper.

Hi . I am having a Postprocessvolume (not unbound) which I am inside, sometimes … but even if I disable it, there is no difference. Apart from that I don’t know if there are any buttons to switch between global postprocessing and per camera. Playing with the PostProcessWeight and the Intensity does as well not make much of difference.

The cameras are all spawned by the sequencer.

Are there any other switches that would make the difference?

Can you reproduce this with a single camera actor and sequencer in a clean, blank project with no additional content?

Hi ,
Found the culprit! I cloned the whole project and deleted parts of the scene one by one.

The issue was gone after I erased another Sequence File that was in the scene! Does that make some kind of sense to you?

Best regards and ahve a good we, Peter