Scene Capture Show Flags not working after Packing game

Hello! I am using Scene Capture to create a radar-like mini map similar to Halo where I am only displaying the enemy locations near to the player. Everything else should be transparent/non-rendered. I did this by going under the Scene Capture tab in the Blueprint and toggling all the show flags off. This is it working in engine (lower left):

But when I package the project to release, it looks like it’s ignoring all of the show flag settings. This is it not working once I package the game (lower left):

What am I doing wrong? I’ve tried messing with all of the package settings and trying different render modes but I always either get the same result or a result that leaves me with a completely transparent map (including the enemy dots).

Hey, sorry this post is a few months old but I wanted to post the solution for anyone else even if you found a workaround - There is a bug (at least as of 4.26) that seems to reset the show flag settings on instances of actors that contain a scene capture to the default settings that actor had when it was first placed, whenever the editor is reopened OR in packaged versions. As a result, scene capture instances that were placed before the parent was modified will have the settings they had when they were placed, regardless of the parent’s current flag settings.


The fix for me was to delete and replace all instances of the scene capture actor whenever I make changes to the flag settings. Slightly annoying, but does seem to fix the issue!