Download

Scanned Poplar and Aspen Forest with Seasons - Spring Update

Support topic for Scanned Poplar and Aspen Forest with Seasons:
https://www.unrealengine.com/marketp…t-with-seasons

Update 1 is live.

Update 1 contains performance optimizations and some improvements:

By the way I almost completed **Update 2. **It will include spring season and some improvements (still WIP):

Here are some screenshots (to view them in high resolution, please right click on images and choose “open image in new tab” ):

I bought it on CGTrader, It’s update there?

I uploaded fist update there weeks ago. I will upload spring update as soon as it’s finished.

Thanks,
was just to be sure

Anyway your work is fastastic (5 stars), unfortunately I cannot vote in UE Marketplate

Thank you :slight_smile:

Update 2 (spring update) is live. You can view new screenshots on product’s page.
I sent it to Epic this morning. I thought they will upload it in two weeks so I was planning to make a new video in this week without hurry. But they uploaded it in 8 hours! Wow :slight_smile:

Update also CGTrader please!!!

Just updated.

New trailer:

Scanned Poplar/Aspen Forest with Seasons - Trailer 2 - YouTube](Scanned Poplar/Aspen Forest with Seasons - Trailer 2 - YouTube)

Good evening,
Let me start off by saying thank you for this amazing pack. Love it. All Devs (indie) need this.

Trying to sort out a Material issue…no matter what I do, or which map, yours or my own terrain, all terrain materials show up as black. Shaders run, compiles, and black. I’ve tried to adjust nodes in the material itself, apply changes etc. No go.

What am I missing?

Thank you very much for your kind words and sorry about that problem.
It gives this error when I convert it from, for example, 4.10 to 4.13. It’s a weird bug I guess. To fix it, I open master terrain material and move a node (doesn’t matter which one), then click apply and save. Unreal recompiles it and fixes the problem. I recompiled and fixed every pack and tested it but somehow for some people it doesn’t work i guess. So you tried this method i guess? Which version do you use?

I had the same issue, black landscape material. After recompiling it just froze with the gray checkerboard default material. Turned out some of the textures were missing. It’s really not a good idea to use textures from the Starter content pack because it’s not really a mandatory part of every project. If someone else has this issue, just migrate over the T_Macro_Variation texture and restart the project. Or unlink the macro texture variation part in the material.

Thanks for the info @Fisher007. Sorry about that guys, I shouldn’t use Starter Content, also Epic should warn me about this. I changed the texture and sent the update to Epic. It should be updated soon.

Hi!
I bought this pack, it looks great, but I have issues with grass. Can’t tune lighting, and grass looks very dark. Tried various settings, inside the foliage asset, and inside asset editor, no result. Please help to solve it.
I attached the screenshot.
Grass parameters:
Cast shadows - False
Ligth map resolution - 16
Other settings by default (doesn’t changed it).
Thank you!

[SPOILER]

[/SPOILER]

Hi @Tirido, waiting for your responce.

Hi @Oleg_Kolyada, sorry about the problem. I did some tests about that. Are you using lightmaps and getting a warning like this, after lighting build is completed: “Landscape_0 Instanced meshes don’t yet support unique static lighting for each LOD. Lighting on LOD 1+ may be incorrect unless lightmap UVs are the same for all LODs.”

I think this is the problem, at least this is the only problem I saw (for foliage paint). Unreal doesn’t support unique lightmaps for foliage instances’ LODs.
https://answers.unrealengine.com/que…g-results.html

If this is not the answer, please give detailed information about scene lighting setup, are these grasses foliage paint, landscape grass type, static mesh etc.

Hi @Tirido, thanks for the reply!
I have no idea how to fix this warning. Some people think it’s just a warning and should be ignored. I tried various lightmaps and shadow settings, the warning still exists. I made the scene with only 3 grass meshes as Instanced meshes, and tried various settings - attached screens.
Static meshes:
SM_grass_a_b_c_d_group
SM_grass_a_b
SM_grass_a_b_spring
Screens:
[SPOILER]
Overview:


LightSource:

World Settings:

SkyLight:

FoliageInstanceActor settings:

Static Mesh - General settings:
SMSettings - General.jpg
Static Mesh - LOD0

Static Mesh LOD 1

Static Mesh LOD2
[/SPOILER]

Unfortunatelly, there is nothing you can do about this warning. Unreal calculates foliage paint lightmaps for just LOD0, so other LODs of the meshes uses LOD0’s lightmaps and they don’t match for other LODs of course and this creates artifacts. But in my tests there were small artifacts, not like your screenshot. In your screenshots all grasses are dark. That’s also strange. Maybe you can force these meshes to have just LOD0 from static mesh editor.

By the way, is there a particular reason why you want to use lightmaps? Actually, for nature scenes, it’s better to have dynamic lighting. LPV and distance field AO would give good results.

@Tirido, I’m not very experienced in lighting, could you please give me some instructions or maybe links to some tutorials for foliage lighting setting?
Thank you!

Sample scenes are set to use Light Propagation Volumes (LPV). This will simulate bounce lighting. But you need to enable it manually first.

Also you can use Distance Field Ambient Occlusion (DFAO).

This is a good, quick overview video about DFAO: