Scaling things makes collision issues

Hi there,

We are developing a video game thats about growing up things and make it small,we are just using the collision mesh settings to: Use ComplexCollisionAsSimple and mesh_phymat. Everthing is ok but we figured out that some collision issues happens when we scale thing in runtime, they doesnt appers quit often but when it occurs it makes the game looks buggy.

Thank you.

P.D. we are testing this issue using only meshes from the marketplace epic examples(we are on prototype phase).

Hi Son1cman,

I’ve been trying to reproduce this on my end but am having difficult seeing any similar results as you’ve described.

It should be noted that using Complex Collision as Simple is not the best form of collision as it’s being generated from the meshes own polygons. For the best results using either Custom Collision made with your 3d software or generating collision and scaling appropriately is the best result.

It should also be noted that if you’re scaling things in significantly larger or smaller you will see potential physics problems.

Try using the generated collision and see if you can reproduce the same results.

Thank you!


Ok, ill try

Im trying to find some documentation on how doing generated collision within static mesh editor but cant find anything

Here you go! :slight_smile:

If you get stuck or have any questions feel free to ask.


Hi tim, ,maybe you can check this video: buggy - YouTube
As you can see while scaling up its not a problem if iam on the top of the mesh, but if im on the sides i have this weird bug. The blueprint is simple im just using event tick and a counter that resets every certain time to update the scale constant.


I’ve tried to get results similar to your setup for a bit now. Can you show me how you’ve got your BP setup so I can get the scaling to work correctly. At this point I should be able to see if there is anything that can be done to improve your issue or if this needs to be submitted to for refinement.



Im sending you the project so you can test it for your self: Dropbox - testBuggy.rar - Simplify your life
Heres a video of the bug: buggytest - YouTube

Scaling things Instructions: you need to aim the object and then press RMouseButton for scale down and LMouseButton for scale up. If you want to add another mesh you just add the tag “Scale” to it.

Walking against the mesh while you scaling up makes no collision error but if you just stays steady bug appers.

As you can see i took the playerCharacter from the content example and just added my logic to it.

Ive been getting results by changing the grow factor variable(default:0.00007) the lower it is the better collision i get.


Hey Kevin,

So with the gracious help of Ben Halliday we’ve managed to track down a solution for you.

In your character blueprint (PlayerCharacter) You’ll need to disable “Trace Complex on Move.”

We were going back and forth between the default character BP and your player character BP because we could get the collision working with that character. We setup a simple cube that would grown on tick without the gun and were finally able to get it narrowed down.

Make sure you’re using either generate collision from within the mesh viewer where you can adjust the collision hulls to fit accordingly or you can create custom collision with your modeling software.

Here is a link to the project file I altered.

The collision may seem a little janky but there is possibly some things that can be done in Blueprints to make this smoother. If you’re having trouble setting that up be sure to post this as a new question in the Blueprints section or the Forums.


Thanks!!! thats terrific to hear… im so great full with you both… im adding you guys to the credits :)… Thanks million you both are rock stars!!!:

i was wondering, just for the sake of the feedback how do you find the ability to scale things in order to explore? it will be terrific a feedback from both of you!!!

Ben suggested taking a look at this post from a few months back where he helped a user with having a door push their character. He managed to get it working fairly smoothly.

Implementing something like this should help smooth things out a bit. :slight_smile: