Scaleform Minimap (Radar) disappears after cooking

Hello guys.

I am finally finishing the first demo of my game, I already created the trailers, I am just now capturing a complete gameplay of the first mission.

I did cook the first mission (map), and it indeed made the game load faster, even the game speed was smoother on the cooked map, however I realized that after cooking the minimap simply disappeared.

Whenever I play the game with uncooked packages, directly from the UDK Folder, it works perfectly, the minimap shows all the enemies there, however in the cooked game the minimap simply disappeared.

Any help?


try running the game with a batch file, does it happend the same?

I never did figure out why my own game was missing so many assets when I ran it cooked. Eventually I just stopped launching the game with -seekfreeloading.

How did you disabled the -seekfreeloading? When cooking with frontend the option looks hardcoded or something as its in a gray box.

Thanks guys for answering me.

So that means I should upload my game to steam uncooked? However I did realize that whenever I ran my game with cooked packages it run smoother, for sure, and the loading time was ridiculous fast! As for running it uncooked, it tooks a LONG time for loading, because it recompiles the material shaders each time I load the map.

I double checked my demo, and it is only missing the radar minimap, as for my other custom flash (swf) files, like mission briefing, headshots indicator, knife kill indicator, mission accomplished, custom weapons icons, they are all there running fine, only the minimap disappeared.

I don’t use the frontend. And I don’t use the UDK-created installer. I make my scripts with MyGame.exe -make (I’m using UE3, not UDK), and then I copy my Script folder (instead of ScriptFinalRelease) into the Steam staging directory. And I copy the Content folder (instead of CookedPC) into the Steam staging directory. Then I use steamcmd.exe to upload the uncooked game to Steam. Then when Steam launches the game, it launches MyGame.exe -user, which basically tells the game “don’t worry about checking to see if scripts need to be built,” and then the game plays just fine on uncooked maps and content packages.

And you’re sure you told UnrealFrontEnd to recook the package with all your Flash movies? Did you try messing with the YourGameEngine.ini [Engine.PackagesToAlwaysCook] section? If you’ve already tried that and it’s just not working, I don’t know what to tell you. Like I said, I never could fix the missing content in cooked files for my own game.

From a technical standpoint you only really need to fix cooked content if you’re playing on consoles, and I don’t think anyone is going to put any future UDK games on consoles. I believe there could be a performance increase on PC. Maybe because of how it handles textures? I don’t know. But you shouldn’t need to rebuild materials every time you load a level. Maybe you can try launching the game with -user and see if that skips the material rebuilding.

From a legal standpoint, there might be issues with redistributing your game uncooked because someone could still run your game with -editor and load the UDK editor. As I understand it, you’re still allowed to create and distribute games with a UDK copy that you’ve already downloaded, but you’re not allowed to redistribute the UDK editor itself.

So how am I distributing my game if it all runs uncooked? The license for UE3 is a little different from the license for UDK, and it’s more flexible because it doesn’t have UDK’s middleware. You just need to work out the details with Epic. If you’re now considering a UE3 license, just make sure you don’t need SpeedTree or Bink. Those for sure aren’t included. I haven’t used Simplygon. I don’t know if it’s included or not.