Scaleform Font Libraries?

Has anyone managed to use font libraries for their scaleform UI’s?

I’ve always embedded the fonts, but would like to use a shared library across all my flash movies (as i need to use Chinese language fonts etc).

I’ve followed this guide: But it just doesn’t seem to work for me. Not sure what I’m missing.

I have got it to work (previously it was using my default system font so i changed it to Arial).

However whenever I publish my flash video, I always get this error:

It will work when I import it into UDK, but i do a lot of testing just in the Scaleform launcher in Flash, so this is a pain.

If i add gfxfontlib.swf to the same folder as this swf, then i get this error:

Error: ActionScript version mismatched between main and import 'gfxfontlib.swf' files

What’s the secret, Coldscooter? I’m trying to do the same, and the crazy thing is, it worked but only for one movie. All the others are showing rectangles for all their text.

I have a movie called Images.fla that I publish as Images.swf. This file contains all of my shared images and fonts. Importing shared images works perfectly. The fonts show up in the Scaleform Launcher when I test from Animator, but when I publish and import into UE3, any place where I use an imported font shows rectangles–except for one file, and I don’t know why the imported fonts work there but nowhere else.

@Nathaniel3W Not sure why it’s not working for you. Maybe make sure that the non-embedded fonts you’re using match that of the shared font library (including their style etc).

Btw, you mentioned you’re using Animator? I’m using flash CS4, even though I’m paying for an Animator licence (because that covers the legacy versions). Is Animator the same to setup? Are you using the latest version?

Thanks. I’ll double-check all the names of the imported and exported fonts.

I just checked, and it seems the name is Animate, not Animator. My bad. Anyway, I’m using the latest Animate and it seems to work OK. I just had to install the Scaleform plugin for it. And in order to do that, I remember I had to download a converter to update the plugin. I like Animate well enough, but there are enough differences that any Flash tutorials out there are now just kind of guidelines rather than instructions. If you decide to give it a try, save some backup copies of all your fla files. Once you save them in Animate, you won’t be able to open them in Flash again.

I took a look at the video you linked above, and that guy had to take a bunch of steps I had no idea about. One problem that I’m running into is that there is no “identifier” when you export/import resources in Animate… unless that’s just the name you give things in the Library. Maybe if I can’t get font libraries to work, I’ll see about using UDK fonts.

And I have successfully broken the font that was working, but got a different font to work inside the same movie. I don’t know how I did either. I’m importing and exporting the fonts the same way.

@Nathaniel3W I’m having trouble installing the Scaleform extension in Animate. Whenever I try to install the extension (using an extension manager) it just says “The extension is damaged or file is not accessible”. How did you convert the extensions file?

I used Adobe Extension Manager CS6. I used it to convert the mxp file to zxp. And then I was able to install the zxp file.

At least, I think that was how it worked. If you can’t get that to work, I’ll see if I can find out where my converted extension file got saved and I’ll send it to you.

Thanks for the response. I got it to work using the old CS4 extension manager converter as you mentioned.

Mostly everything is working and it runs MUCH faster than Flash CS4.

I do get an annoying error when running in debug mode: “Frame label default not found in scene default”. It seems keyframe labels aren’t detected. Not sure what’s going on there. Nice to know i have it mostly working though.

Do you by any chance have a fontconfig.txt file in the same folder as your gfxfontlib.swf? If so, what’s in it?

Edit: Nevermind. I’m doing a lot of experimenting and I think fontconfig.txt is irrelevant.