Download

Scale uniformity

Hi people, I couldn’t find an appropriate section so here we are.
I’ve been trying to work with real world scale which have been a pain but I noticed something as I tried to scale my character’s capsule to match the environment.
I placed a cube next to what would be a character collision capsule and set both of their Z scale to 500 (5 meters) and this is what I got. Why is this happening?
image

  1. Set both objects to uniform scale
  2. Adjust the capsule size to equal the box (use properties, not scale)
  3. Set Z scale to 500 on both objects

A 200cm cube scaled by 5 becomes 1000cm tall. Likewise, a 300cm cube scaled by 5 becomes 1500cm tall. You shouldn’t scale the collision capsule anyway, as it may affect your Movement Component.

The capsule properties don’t provide accurate measurements either. I’m using a base 1x1x1cm cube to give you more context.
Here are the parameters of the capsule, how can I set it to be as tall as the cube (500cm) ?
image

Set the capsule’s scale to 1, 1, 1. Set the Capsule Half Height to 250cm.

I did that too before replying. The outcome was so ridiculous that I didn’t think it was worth mentioning.
This is what it looks like:

Hi again, I don’t know why or how but 25000 worked!
If you know why the capsule uses a subunit other than centimeters then please let me know :slight_smile:

Default capsule half height is most definitely in centimeters across all engine versions I have ever used.
Don’t believe me?
Check the class c++ code. It’s right there all neatly written up.

If you are using a custom class, than maybe that class is at fault.
You’d really have to go out of your way to change the capsule component properties though, so whoever did it must have had a real need presumably.

Since you didn’t say what engine this is on.
If it’s on ue5 you may want to double-check and then file a bug report…

Hi there, I’m using 4.27.
I’m a BP guy so I don’t really have the expertise to check the code myself but I’ll take your word for it.
I also thought my class was faulty at first but then did the same thing with a regular collision capsule and I had the same outcome.
Most of people advise me to refrain from altering the capsule component but what I don’t understand is how would I achieve a real world scale scene without doing so? Should I just work in Centimeters with a ratio? And thanks!

I’m not sure what you are getting at.

Unreal units float between 1cm and 100cm - because there’s too many cooks in the code kitchen so they often create a component and bungle up the fact it’s supposed to be size in cm.
Usually, those issues (like on road splines) get reported and solved-hey at least they used to. it’s true that in the last 2 years this hasn’t been true.

So in other words, the worlds built in engine are already the correct world scale.

When modeling outside the engine and importing - that’s the only moment you need to worry about scale. Most DCC do whatever the f they want in terms of units - it’s the nature of the beast really. When modeling things you may need to go from picometers scale to a foot scale at a moment’s notice without the model changing…
Note: animations in blender key-frame the scale, so it’s highly recommended you set things up properly First, then work and export.

Like they mentioned above
100x, 100y, 500z - is the size of a 1x1x5m cube.
Regardless you shouldn’t be changing any of that in engine if not for testing purposes.

if all of the above doesn’t help, try to explain what you are trying to do like you would to a five year old. It’s very possible that you’ll realize how stuff works yourself when you think about it in basic terms - or that you can actually give us missing information…

I’m new to UE so please bear with me.
In very simple terms, I want my character to be half as tall or so from the walls surrounding him.
Let’s say I’ve modeled a 300cm tall wall, how do I set up my character to be like 150cm tall or so?

When I drag and drop the default character blueprint into the level, it appears as small as a grain of rice compared to the wall next to it and I don’t want my character to be an ant for that matter.

I think the wall you modeled is 300m tall, not 300cm tall.
Either that, or you went in and messed with the engine scale settings?

Assume the character is right. Since by default is around 160cm tall (the capsule anyway)…

1 Like

I don’t know how to tell you this but now I can see how silly the problem was and it is exactly what you’ve stated here (I also forgot to apply scale before exporting)

I think the wall you modeled is 300m tall, not 300cm tall.

Learning 2 big software at once can really break your brain. Anyways, thanks for putting up with me and have a good night/day.

1 Like