Scale meshes 50 to 100 times crash engine

If you import a mesh done in Blender for example and generate for it the collisions using the mesh editor with the convex tool and default settings (make sure it is not a sphere or something too simple, need something that is at least 2 parts or something) then place is the world scale to 100 for example, press play with some pawn active etc and crash of PhysX.

*Note I got enabled the world origin, and play from camera pos at about 2km from world center.

*Log: PhysX3PROFILE_x64!physx::Bp::PersistentSelfCollisionPairs::findOverlaps() [d:\build++ue4+release-4.15+physx_compile\sync\engine\source\thirdparty\physx\physx_3.4\source\lowlevelaabb\src\bpsimpleaabbmanager.cpp:1205]
PhysX3PROFILE_x64!physx::Bp::SimpleAABBManager::updatePairs() [d:\build++ue4+release-4.15+physx_compile\sync\engine\source\thirdparty\physx\physx_3.4\source\lowlevelaabb\src\bpsimpleaabbmanager.cpp:2287]
PhysX3PROFILE_x64!physx::Bp::SimpleAABBManager::postBroadPhase() [d:\build++ue4+release-4.15+physx_compile\sync\engine\source\thirdparty\physx\physx_3.4\source\lowlevelaabb\src\bpsimpleaabbmanager.cpp:2458]
PhysX3PROFILE_x64!physx::Cm::Task::run() [d:\build++ue4+release-4.15+physx_compile\sync\engine\source\thirdparty\physx\physx_3.4\source\common\src\cmtask.h:59]
UE4Editor_Engine!TGraphTask >::ExecuteTask() [d:\unrealengine\4_15_wind\engine\source\runtime\core\public\async\taskgraphinterfaces.h:883]
UE4Editor_Core!FTaskThreadAnyThread::ProcessTasks() [d:\unrealengine\4_15_wind\engine\source\runtime\core\private\async\taskgraph.cpp:1277]
UE4Editor_Core!FTaskThreadAnyThread::ProcessTasksUntilQuit() [d:\unrealengine\4_15_wind\engine\source\runtime\core\private\async\taskgraph.cpp:1171]
UE4Editor_Core!FTaskThreadBase::Run() [d:\unrealengine\4_15_wind\engine\source\runtime\core\private\async\taskgraph.cpp:643]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\unrealengine\4_15_wind\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:76]

Hi, I tried with a several part mesh, creating the convex collision with default settings, placing it about 2km from origin, same as player start, but I cannot reproduce the crash.
Can you give more details about your scene setup?

Call can’t tell you much more scaled meshes in world at x100 and with convex generated collision in UE4 and at play give PhysX report I already send the log to Epic but no idea what is I can’t provide the scene cause is a private project.

Can you go to project/Saved/Logs and give us the latest log with the date?

Posted the crash log

Today happen just after update the exposure…

Just now I can’t even press play anymore

Only fixed it at move the camera from location and press play, this is getting really absurd/rare

Hey ,

Can you attach an fbx and the source blend file for a mesh that reproduces this? If it’s too big, you can PM me a download link on the forums.

Is not just one mesh are all the meshes in the project, is rater UE4 doing rare things, can’t get the error anymore are these rare things that happen in the engine, out of the info I give can’t give nothing more since the project is private etc. If got more info will post.


Marked as resolved for tracking until more info is available.

Well the problem is back looks like at edit the terrain from the landscape aka the visible zones or sculpt it and then press play this crash happen…

Please take note of all first things I said the worl origin shift is enabled and the landscape is easy about 15x15Km froma scaled 4-8x4-8Km one

As always, we need a way to reproduce the issue on our end using steps provided by you. If you can provide me with those steps, then I am more than happy to assist with the troubleshooting process.

I’ve attempted to scale a large landscape up with World Origin enabled, but I am not getting a crash on my end.