Scalability settings cannot be changed after using console commands

My game can change scalability settings in-game by pressing F1-F4. I achieve this by executing console commands (see below). After playing in editor and changing the settings by F1-F4, something gets broken. I can no longer change the scalability settings from the editor’s menu. Sometimes some of the settings work (for instance I can change to Medium, but not to High etc). Other times I can change to nothing. I am using 4.8, I don’t think I had this problem with 4.7. Note that since I am playing in editor, pressing F1-F4 also has other effects (wireframe, unlit, lit etc).

  • sg.ShadowQuality 0-4
  • sg.TextureQuality 0-3
  • r.ScreenPercentage 85-100
  • r.PostProcessAAQuality 0-4
  • sg.EffectsQuality 0-3
  • r.ViewDistanceScale 0.55-1

(The values on the right are the range which I use depending on F1, F2, F3, F4)

Hello dimitrov,

If you would link a screenshot of how you have your keys set up to change these settings.

I am assuming that you are using a blueprint to achieve this.

If not please explain how you have set up your F1-F4 to change above mentioned values.


Hi ,
Yes, I am using the Level Blueprint for this. Two screenshots attached.

Hello dimitrov,

I recreated your level blueprint and I was able to view the changes when previewing inside of the viewport.

I then quit the preview and went to the Settings > Engine Scalability and was able to change the settings by manually changing them around.

How exactly are you changing the engine scalability when you experience this issue.


I really want to help but I’m not sure what else to tell. Let me go step by step.

  1. I start the editor. My editor starts
    with two windows, there is a second
    viewport that I always have open.
  2. I hit “play in selected viewport” and the game starts in Viewport 2.
  3. I press F1, F2, F3 and F4 a few times (so both viewmode changes to wireframe, unlit etc, AND my commands for quality are executed)
  4. I minimize viewport 2 (or press Esc to stop the game) and change the scalability settings from the main window - from the drop-down menu. I try with all options (low, med, high, epic).

What happened today was that the textures and effects settings stayed on medium and could not be changed by pressing low, high and epic. The shadows setting stayed on high. The rest were changing according to what I press.(vierw dist, anti-al, post-proc).

In case that’s relevant I used my project for Oculus VR, so I also have settings for VR like “hmd sp 60” that I run the same way through console command in level blueprint. I also have three commands that are executed on event beginPlay - fullscreen, r.ScreenPercentage 100, Enable HMD.

I hope that helps.

At this point without your actual project there is little more that I can do.

I was not able to reproduce your issue in a test project utilizing only the scalability functions that you created and bound to F1-F4.

In order to create a test with all factors the same I would need your


Let me know if this is what you want to do.


Thanks for offering further help. I am not doing this out of personal interest, as much as because I want to help out by reporting a bug. I would not like to share my full project, so I’ll leave it to you from here. Let me know if you have further questions. Cheers!

I had exactly this problem today. Working in 4.9 at the moment.

When I change a Scalability setting with keyboard it changes. But in the editor these changes cannot be undone.
I either have to go back into the simulation and press one of the keys.
Or restart Unreal and than it works again in the editor.

If I play the game and press key again, same problem.

Hello Beervangeer,

I am sorry you are experiencing this issue as well.

After a bit of research I have discovered this is a known issue. In order to once again change the engine scalability settings manually please follow these steps.

1.) In your console commands enter r.ScreenPercentage.Editor 10
2.) Then Under Settings >> Engine Scalability, set the Resolution Scale to 100

RESULT Screen resolution changes after console variable is entered and again afterward by slider.

EXPECTED You should not have to enter an additional command in order to use the slider

The bug number is UE - 18470

Thank you very much for reporting this issue,

I’m having the same problem in 2020. I have a solution that worked for me though.

I used the settings sg.EffectsQuality 0 sg.ShadowQuality 0 r.ScreenPercentage 40

Ok with this said. I then had to rebuild my geometry and rebuild my build texture streaming. I hit save. Once I did this it finally let me use these settings. It may have just been using the geometry rebuild and texture streaming rebuild… I dunno.

Hopefully it helps someone out faster than I got help… took me a day to finally get it working!