Scalability Reference does not apply to standalone Game

Hi,

I want to report here a problem with official documentation of [the Scalability Reference][1]. This leads to many (mostly unanswered) questions here and in the forums.

My reference for the following tests is the “Quick Settings” menu described by the blog post on [How to Improve Frame Rate Through Video Settings][2]. This menu we provide 7 settings group that does affect rendering inside the Editor (but not in a Launched/Packaged Game):

Here is the result I want to get:

4360-ue4editorscalabilitysettings.png

Theoretically, a game could use the 7 corresponding commands described int [the Scalability Reference][4], but they are currently not (all) working.

I’ve tested them with the console, and in fact only individual settings are known to the console; group commands are not recognized and do not work. Here is the list of the 7 commands (where “r” might be for “Render”);

  1. r.ScreenPercentage 25
  2. r.ViewDistanceScale 0.4
  3. r.PostProcessAAQuality 0
  4. r.PostProcessingQuality 0
  5. r.ShadowQuality 0
  6. r.TextureQuality 0
  7. r.EffectsQuality 0

Only the 3 first are known and working in the console; they are in fact individual settings, whereas the 4 others are groups of multiple individuals settings (defined in the config file BaseScalabitity.ini).

But thanks to @amiserablerobot I’ve found the corresponding 7 working commands (where “sg” might be for “Settings Group” or “Scalability Group”);

  1. sg.ResolutionQuality 25
  2. sg.ViewDistanceQuality 0
  3. sg.AntiAliasingQuality 0
  4. sg.PostProcessQuality 0
  5. sg.ShadowQuality 0
  6. sg.TextureQuality 0
  7. sg.EffectsQuality 0

And thanks to @Jacky, here is how I configure the all settings to their minimum:

To test it, just set all settings to anything above “Low”, than “Play” the Level, and then check in the menu that all settings has been set to “Low” like in the first image.

Cheers!
SRombauts

See also:

  1. [(AnswerHub) Trouble configuring game settings][6]
  2. [(Forums) How to improve frame rate][7]
  3. [(Forums) Editing graphics settings for gameplay][8]
  4. [(YouTube) Tutorial on a settings menu][9]

There should be way to set this up in default settings INIs instead of hard coding configuration in blueprint

1 Like

Oh yes, for sure, and perhaps such an INI file already exists, but people have tried without success, and our questions over there remains unanswered…

The point with Blueprints is that you rarely want to enforce graphic settings to everybody; you want some form of dynamic settings, often by the means of a “settings menu”.
I am using direct touch binding for that;

4367-ue4ingamesettingswitching.png

Did anyone ever figure this out in a way that doesn’t require building off of some sort of input trigger?

I’m trying to trigger “sg.shadowquality 0” automatically on game load in a baked game.

Ha! You are right. I had tried that before and it wasn’t working but I must not have saved before packaging.

Cheers!

Yes I did, look at my first answer above, I uses the BeginPlay event.
Cheers!

Hi everyone,

I apologize for this post having gone unanswered, it apparently was buried and overlooked. However, I do believe these exec commands should be working as intended. If they are not, please comment back here, I am assigning this page to myself so it does not go missing again!

Just tried this with 4.41 preview on Oculus Rift. I set everything to low on Quick Settings, but neither packaged game nor standalone game seems to actually use these settings.

Are we doing something wrong?

Applying quick settings is only going to affect things while you are playing in editor. In order to get the settings to stick in a cooked or standalone game you need to use the blueprint execute commands listed above.

Choose the ones you need, enter them, save, package, and there you go.

If you are doing a C++ project you can just add these values to the DefaultEngine.ini and it seems to work for me.

r.ScreenPercentage=25
r.ViewDistanceScale=0.4
r.PostProcessAAQuality=0
r.PostProcessingQuality=0
r.ShadowQuality=0
r.TextureQuality=0
r.EffectsQuality=0
sg.ResolutionQuality=25
sg.ViewDistanceQuality=0
sg.AntiAliasingQuality=0
sg.PostProcessQuality=0
sg.ShadowQuality=0
sg.TextureQuality=0
sg.EffectsQuality=0

Please i really need the answer to this question, im packing games for windows but even if i set lowest quality possible, the packed game still in best quality when i excecute it after cooking it, please is important im i need send my projects to some people with low spec computers.

Hi Ruken,

What steps are you taking when attempting to set the graphics settings outside of the editor?

I have not tried shipping build, but with development build you can set these settings in GameUserSettings.ini

like so:

[ScalabilityGroups]
sg.ResolutionQuality=80
sg.ViewDistanceQuality=1
sg.AntiAliasingQuality=2
sg.ShadowQuality=0
sg.PostProcessQuality=2
sg.TextureQuality=2
sg.EffectsQuality=2

Hey, sorry to bring up old topic.

Can these settings be set by users like the settings window for their computers?
Like using widgets in the main menu and having players set settings or do these have to be set permanently before packaging?

HI TobiasRipper,

This question would be best answered in the blueprints section of the forums. I’d highly recommend posting there to further discuss this.