SBTarget invalid

Hi Everyone,

I finally got ue4 editor running on my mac, hurrah for me… well maybe not. so i tried pushing to my phone, and realised i was using the debug version. so a thread on how to change the scheme to development.

so when i do this, rather that the 337 jobs that xcode has to do there is not 612, makes sense as more to deal with.

But it seems to get stuck on 162/612 compile module.desktopplatform.cpp. been stuck on this for 3 hours. ive re-downloaded all the files and tried fresh. still no luck

[edit] while typing this it completed. but now kicks out a SBTarget is invalid. i did set it to ue4editor - mac

Any ideas?



well i worked it out…

Thought i’d share as I’m sure many people will run into this one.

basically when you change from debug to development under scheme, you need to make sure you change the executable. from ue4editor-debug, it wont show in the list so you have to click other then search for ue4editor.
This will stop the invalid SBTarget…

Now onto why its taking over an hour an half to push to an ios device. UDK was quicker by a country mile to push to a device… whats up with that.

Could you please explain, what do you mean by change the executable?


I just wanted to check in with you and see if you have been able to ‘change the executable’? If you have, please let me know so that I may be able to mark this issue as resolved.

Thanks and have a great day!


We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.