Saving takes forever

…because every single time I save, it has to recompress and write to disk something called “HQ_Lightmap_106”. I’m pretty sure it’s related to one of my speedtrees, but I can’t really tell. It’s interrupting my flow to wait for 45-60 seconds each time I hit save - how can I fix this?

Perhaps you have a lightmap set to some insane resolution for an asset?

Not sure, I’ve never adjusted a lightmap before. To add more detail, it only does it after I play in the editor. After that, the first thing saved is that lightmap. It’s quite annoying.

Is there a way to tell which asset that lightmap belongs to? Maybe I need a vashikaran specialist.

I’m not sure what his going rate is, but make sure to read the EULA first. :wink:

If you have a lot going on in your level it may take a bit for it to save. You can disable the automatic saves or set a different save interval in the Editor Preferences.

As for lightmaps size, an increased size will make your build times longer but I don’t think it would affect your saves time as much. I’ve got a pretty hefty project going right now with around 9000 objects in my scene and the automatic save can be annoying and it takes around 15-20 seconds for mine to save. It’s an interior scene. I suppose using landscapes with lots of foliage over a wider range would cause this as well.