Savegames not working on iOS

Hello dear community,

We’ve been trying to get savegames to work in our project on iOS without success. At first we tried with a C++ implementation, which works fine in the editor, but not under iOS.

Then we decided to try with a simple blueprint implementation using the third person template, which also works fine in the editor – attached you can find the screenshots.
As you can see, we’re loading and saving the player location at begin play and logout respectively, but we also tried to bind the save and load functions to the touch actions to be able to do it manually on iPhone, but that doesn’t work as well.

Do you have an idea what we’re missing here? We’ve searched everywhere for a solution but couldn’t find anything so far.
We tested this with different UE versions without success - 4.22, 4.25 and 4.26

Here’s the link to download the test project for you to test yourselves and see how we exactly implemented it.

Thanks in advance for the help!

Two things I notice there.

  1. You’re creating the save game every time you save, which will wipe anything already saved. This might be because it’s just a demo, but…

  2. Use the non-async versions. You only need async if you have like 500mb of stuff to write. And these nodes fail quietly.

Thanks for the quick answer!

  1. Could you please suggest a way you would do it?
  2. We already tried with the non-async version. Same result.

hey, I’m back to let you know that your suggestion works great in our project. Thank you very much for the quick response. Hope this helps other people in the future too :slight_smile:

Save game 101 goes like this:

1 Like