Download

Sample Rate Quality presets are not working

Hello,

I am using UE4.25 and having a problem with sound waves quality sample rate presets. I am trying to set different sample rates for audio files to optimize memory usage but do not see and hear results in a game. For example I suppose setting lowest quality I should not hear hi freq at all but there is no change.

I thought that mb I should set up presets in the project settings first. See the attached picture. But it did not help. What should I do to use this feature properly?

Thanks for the heads up, we have found some issues with this feature.

First you will want to turn on the flag “Resample for Device,” which is listed above your red box in the Cook Overrides section.
Second, we’ve noticed a bug where you have to wiggle the Compression setting to get it to recook the asset.

We’re looking into any other bugs associated with this feature right now as we are currently updating our sample rate library.

Hello Dan,

Thank you for your answer.
Our project is on 4.26 now. I tried what you suggested but what I experience is:

  1. Some assets which receive lower sample rate are just playing slower. Both in the cue preview and in a game. I.e. setting 22kHz makes the assets playing two times slower.
  2. Some assets just ignore settings and do not change their settings. No hi freq loss.