Download

Runtime Virtual Texture flickers when sampling it on grass

Hi. I have this issue where my Landscape Runtime Virtual Texture (RVT) is flickering (popping between mips) when adding for example grass, which samples RVT in its material (or rocks)
I started experiencing this issue when I moved my project from 4.26 to 4.27.
Example : W1NOVvJr2m - YouTube
I’ve tried making a new landscape, reseting my configs, adjusting various settings with no luck. As soon as I sample the RVT on any other object than Landscape, it starts flickering. I am so lost, and I’ve been trying to find the solution for 2 months with no luck.
I am looking for any tips or opinions on what could cause this. Thank you for you time.

Still experiencing this issue and have no idea what causes it? Is it lack of VRam? (8gb)

Bcoz your landscape is overlapping each other

Hi vaibhuvps!

I see that you recently joined our community! We’re SO excited to welcome you! There’s so much you can do here! Earn badges through participation! Explore the forums! Find out what’s new! Post any questions! Share any of your creative works! Here are our Community Guidelines on how to be the best member you can be. Thank you for being an important and contributing part of building a stronger community! :man_technologist:t4:

Based on my testing, sampling more than one RVT is what’s causing the flickering issue, in my case. Have no issues whatsoever in 4.26, in the same boat as you trying to update to 4.27.

Here’s a video to illustrate: UE4 RVT Bug - YouTube

1 Like

I am sorry you are too experiencing this issue but THANK GOD I am not alone!!
This must be a bug. Epic, please respond! I will be submitting a bug report tomorrow if I am able to reproduce it in a clean project.

Thank you for the reply, however this is not the problem I am afraid.

Were you able to confirm that like me, the issue arises after sampling more than one RVT? I am DYING to use 4.27 but I can’t since I heavily use RVTs. Many of them. :frowning:

I am recreated this in a new project so that I can do a bug report and all that.

1 Like

Yes, I confirm, the problem arises when sampling the RVT more than once. If I sample it only on my landscape, all is fine. If I sample it on rocks for example, begins the flickering!
Please do report if you will, this will help us get going faster, I am trying to find a solution for 2 months now and its really holding me off!

Issue recreated in a new project. Bug report submitted. I’ll keep ya posted when they respond

1 Like

Thank you very much, please do share the link to the bug, so I can upvote it or something.

Any update on the bug tracker?

I am happy to announce that the problem has been solved. After trying to reproduce the problem in a clean project, I noticed the flickering issue appeared when a Texture2D had “Virtual Texture Streaming” parameter checked (when used in landscape material, even if the texture with this parameter was used after sampling the RVT). So I batch unchecked that checkbox on every texture used in the level and the issue no longer persists. Not sure if it is a bug or limitation. Thank you everyone for the help

I had the same issue. Decided to share the results. Apparently the memory pool for virtual textures is full. Just increase the values ​​in the BaseEngine.ini configuration file. You’ll find these settings under the [/Script/Engine.VirtualTexturePoolConfig] .