Download

Running into Problems with UnrealMultiUserServer Failed to Create Session

I’m running into some issues here, and I can’t seem to find the actual documentation associated too this anywhere though.

LogConcert: [Pending] Creating Session 'test'...
LogConcert: [Pending] Creating Session 'test'... - Validating Workspace...
LogSlate: Took 0.007360 seconds to synchronously load lazily loaded font '../../../Engine/Content/Slate/Fonts/Roboto-Light.ttf' (167K)
LogConcert: [Pending] Creating Session 'test'... - Attempting Remote Connection...
LogConcert: [Pending] Creating Session 'test'... - Attempting Remote Connection... - See Details...
LogConcert: Error: [Failure] Failed to Create Session 'test' - Session 'test' could not be created, no session repository was mounted to store it - See Details...
LogSlate: Only BGRA pngs, bmps or icos are supported in by External Image Picker
LogSlate: Window 'Project Settings' being destroyed
LogSlate: Window 'Project Settings' being destroyed

Is the Log output in the UE4 Editor’s Output Log.

Failed to CReate Session, session could not be created no session repository was mounted to store it.

Now I can’t seem to find any reference too this, following the official documentation. They don’t show this error at all as a potential issue.

{
        "Repositories": [
                {
                        "RepositoryId":
                        {
                                "A": -1974527236,
                                "B": -1049868433,
                                "C": -1501791979,
                                "D": 634057176
                        },
                        "RepositoryRootDir": "",
                        "WorkingDir": "../../../Engine/Programs/UnrealMultiUserServer/Intermediate/MultiUser",
                        "SavedDir": "../../../Engine/Programs/UnrealMultiUserServer/Saved/MultiUser",
                        "ProcessId": 12257,
                        "bMounted": true
                }
        ]
}

Is the JSON from ~/UnrealEngine/Engine/Programs/UnrealMultiUserServer/Saved/MultiUser

My file permissions are

devuser@umu-instance-vbrfu:~/UnrealEngine/Engine/Programs/UnrealMultiUserServer$ ls -la
total 16
drwxr-xr-x  4 devuser devuser 4096 Aug 28 12:42 .
drwxr-xr-x 13 devuser devuser 4096 Aug 28 12:20 ..
drwxr-xr-x  2 devuser devuser 4096 Aug 28 12:04 Config
drwxrwxr-x  5 devuser devuser 4096 Aug 28 12:42 Saved

my Engine.ini is

devuser@umu-instance-vbrfu:~/UnrealEngine/Engine/Programs/UnrealMultiUserServer/Saved/Config/LinuxNoEditor$ cat Engine.ini 
[/Script/UdpMessaging.UdpMessagingSettings]
EnabledByDefault=True
EnableTransport=True
bAutoRepair=True
MaxSendRate=1.000000
AutoRepairAttemptLimit=10
bStopServiceWhenAppDeactivates=True
UnicastEndpoint=0.0.0.0:0
MulticastEndpoint=230.0.0.1:6666
MessageFormat=CborPlatformEndianness
MulticastTimeToLive=1
EnableTunnel=False
TunnelUnicastEndpoint=
TunnelMulticastEndpoint=

Now I can connect via my VPN np, and I can see the Server and the editor see’s it as well. But when I try to create a new Session, the error as discussed above happens. I would love to solve this, so others who run into this problem may also find it helpful.

I have already used: Multi-User Editing Reference | Unreal Engine Documentation
As well as: https://cdn2.unrealengine.com/unreal-engine-remote-multi-user-editing-guide-404332864.pdf
And have built a complete Stand Alone Unreal Multi-User Server in GCP utilizing this as a base: https://cdn2.unrealengine.com/unreal-engine-multi-user-cloud-setup-360515954.pdf

But I am missing anywhere it says about folder permissions, or anything else. Would love a helping hand~

devuser@umu-instance-vbrfu:~/UnrealEngine/Engine/Programs/UnrealMultiUserServer/Saved/Config/LinuxNoEditor$ cat Engine.ini 
[/Script/UdpMessaging.UdpMessagingSettings]
EnabledByDefault=True
● umu.service - Unreal Multi-User Service
     Loaded: loaded (/etc/systemd/system/umu.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2021-08-29 07:14:14 UTC; 1 day 13h ago
   Main PID: 19521 (sh)
      Tasks: 20 (limit: 19198)
     Memory: 32.1M
     CGroup: /system.slice/umu.service
             ├─19521 /bin/sh /home/devuser/umu_service.sh
             └─19522 /home/devuser/UnrealEngine/Engine/Binaries/Linux/UnrealMultiUserServer -ConcertIgnore -UDPMESSAGING_TRANSPORT_UNICAST=100.90.236.5:8888

Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.05:078][704]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.05:078][704]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.05:078][704]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.06:084][824]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.06:084][824]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.06:084][824]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.07:073][942]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.07:073][942]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 19:51:08 umu-instance-vbrfu sh[19522]: [2021.08.30-19.51.07:073][942]LogUdpMessaging: Warning: Waiting for ack too long. Re-sending.
Aug 30 20:04:22 umu-instance-vbrfu UnrealMultiUserServer[19522]: LogConcert: Error: An attempt to create a session with name 'test' was made, but the server did not have any repository mounted to store it!
~

Server Logs

make sure you setup your

-CONCERTWORKINGDIR=~/WorkingDir 
-CONCERTSAVEDDIR=~/SavedDir

within the Settings, it does it by default but the actual setup seems invalid, it does …/…/… which puts it in a portion where it does not have permissions.

If you set these with the run command, you’ll be setup. Make sure you change the paths to where you need them. And set them with u+rw permissions.