Download

Running C++ project crashes editor

Hi All,
I installed unreal engine yesterday on lubuntu 15.04, it runs fantastic! I tried a quick blueprints works great, tried a quick c++, ran great. I noticed I didn’t have an editor/IDE and could only select Kdevelop. I did this installed it, had a quick look and went to bed. I rebooted this morning all, started up selected new C++ project, it said creating project, then crashes. I looked inside the project, it had a number of directories and files including a makefile. So I thought I’d try make, it ran for quite a while then crashes 0n ( I think ) linking so physx libs. I’ve tried to open a c++ project again, it reports an error on missing files, then crashes. If I try new project c++, it produces files and directories but always crashes on opening the editor. Blueprints projects work fine.
Can anyone advise please? The error on make is below. I’m unsure why it’s calling these or why they aren’t there. It did appear to work on testing last night before I installed Kdevelop, thought this might be a false reason.



[142/142] Link UnrealFrontend
-------- End Detailed Actions Stats -----------------------------------------------------------
Total build time: 327.31 seconds
bash "/home/tony/Dropbox/UnrealEngine"/Engine/Build/BatchFiles/Linux/Build.sh UE4Editor Linux Development  
Building UE4Editor...
Using clang version '3.5.2' (string), 3 (major), 5 (minor), 2 (patch)
/bin/sh  -c '/bin/sh "/home/tony/Dropbox/UnrealEngine/Engine/Intermediate/Build/Linux/x86_64-unknown-linux-gnu/UE4Editor/Development/FixDependencies.sh" && touch "/home/tony/Dropbox/UnrealEngine/Engine/Intermediate/Build/Linux/x86_64-unknown-linux-gnu/UE4Editor/Development/UE4Editor.link"'
Performing 1 actions (5 in parallel)
[1/1] FixDeps UE4Editor
Fixing libUE4Editor-Landscape.so
/usr/bin/ld: cannot find -lLowLevelPROFILE
/usr/bin/ld: cannot find -lLowLevelClothPROFILE
/usr/bin/ld: cannot find -lPhysX3PROFILE
/usr/bin/ld: cannot find -lPhysX3CharacterKinematicPROFILE
/usr/bin/ld: cannot find -lPhysX3ExtensionsPROFILE
/usr/bin/ld: cannot find -lPhysX3CookingPROFILE
/usr/bin/ld: cannot find -lPhysX3CommonPROFILE
/usr/bin/ld: cannot find -lPhysX3VehiclePROFILE
/usr/bin/ld: cannot find -lPxTaskPROFILE
/usr/bin/ld: cannot find -lPhysXVisualDebuggerSDKPROFILE
/usr/bin/ld: cannot find -lPhysXProfileSDKPROFILE
/usr/bin/ld: cannot find -lPvdRuntimePROFILE
/usr/bin/ld: cannot find -lSceneQueryPROFILE
/usr/bin/ld: cannot find -lSimulationControllerPROFILE
clang: error: linker command failed with exit code 1 (use -v to see invocation)
-------- End Detailed Actions Stats -----------------------------------------------------------
Total build time: 104.92 seconds
Makefile:190: recipe for target 'UE4Editor' failed
make: *** [UE4Editor] Error 5


Thanks

Hi All, I’d just like to add to this I’ve tried a couple of reinstalls and still get the same error.
So I thought I’d try a fresh install and use the QT set up from “https://wiki.unrealengine.com/Running_On_Linux” , I would rather use QT. So added the patch, and the mod to the config. Tried to run, this time it crashes on starting up the editor not on c++ project selection. I tried VIM and codeblocks as well, exactly the same, but an error block opened. So I tried to open the editor via a command prompt, to view what was going on I can see this is reporting and error , the same error whatever IDE I try to use.



[2015.07.25-10.23.58:344]  0]LogLinux:Warning: dlopen failed: /home/tony/Dropbox/UnrealEngine/Engine/Binaries/Linux/: cannot read file data: Is a directory
[2015.07.25-10.23.58:344]  0]LogModuleManager:Warning: ModuleManager: Unable to load module '/home/tony/Dropbox/UnrealEngine/Engine/Binaries/Linux/' because the file couldn't be loaded by the OS.


I can see from the above it isn’t pointing to file? So assume using KDE or adding the patches for another IDE changes some config but it isn’t changing it correctly? EG adding the file name onto the path?
Can anyone who uses linux (ubuntu/lubuntu 15.04) offer any advise ? I think there’s something wrong with the set up or I’m doing something wrong , missing a step?
PS the error box shows



Plugin 'QTCreatorSourceCodeAccess' failed to load because 'QTCreatorSourceCodeAccess' could not be loaded. Maybe an operating system error or the modual may not be properly set up'


should also add the is a QTCreator… directory and a QTCreatorSourceCodeAccess.unplug inide this directory

Thanks all

I have the same error now and i don’t know what do i do. :confused:

Hi there

  1. Creating a c++ project will not open the ue4 editor. It is not a crash.
  2. Neither will be qtcreator or kdevelop opened after creating c++.
  3. Your qtcreator accessor seems not compiled correct. Usually if you compile the editor it will be compiled too. Check for errors and make sure you cloned the accessor which is on the wiki page.
  4. Which version of ue4 are you using?

For full IDE integration and less stress getting your c++ projects started use ue4 4.9 and CodeLite because that should work on gnu/linux until the day some comes and fixes the stuff for kdevelop and qtcreator. If you want to use qtcreator accessor talk with ifire in the ue4linux irc channel.