Download

Running animation not replacing idle animation when running forward

Hello I am trying to follow the examples on youtube about replacing the 3rd person character in the 3rd person blueprint. I have followed the steps and replaced the model with my model and imported my animations, created a blendspace and character blueprint with idle/run state and speed/IsInAir goodness. My character shows up and the idle animation plays great but when I press forward the running animation does not play no matter what I try. Has anyone ever had a problem like this? Please help if anyone knows anything about this thank you.

-which tutorial do you mean? the one from epic or from metalgamestudios :slight_smile:
-do you get any errors when you press “compile”?
-do you have a speed variable + is it connected with the blendspace

I have tried to use the one from metalgamestudios. I have made the speed variable as well as the “IsInAir?” and connected it to the blendspace. I have also defined the channel in blendspace to be from 0-375 and also named speed. I am going to try making a new skeletal mesh test to see if it has something to do with the character.

I’ve tried it with another skeletal mesh and I get the same problem. I’ve attached pictures for you to see if you can figure out what I’m doing wrong.
I have imported the skeletal mesh and both animations and made a blendspace 1D as seen in the browser.

3d5a8fc17414b63b44b4fea654480b792808e604.jpeg

I have dragged and dropped both animations on to the axis and changed the parameter title to Speed and range to 0-375. The plank is supposed to flap when running and spin when not moving.
8f61b69d665041810d27172dc83e14111af25b68.jpeg

I have copy and pasted the 3rd person blueprint graph to the plank blueprint graph and also compiled/saved.
c99604da609e668b4db847f85cf2d07d297afc23.jpeg

I have created a “state machine” with a Idle/Run state and have this graph inside of the Idle/Run state with both Speed float and IsInAir? boolean.


Finally I have replaced the default skeletal mesh with the plank skeletal mesh and clicked the plankAnimationBlueprint for the animation source.

Do you notice anything that I forgot?

The event in the anim graph that triggers everything, is it called “… COPY”? :slight_smile:
But you havent connected the “IsinAir” with any of the idle/running states? → just for the transitions between idle/run and jump?

omg yes. I think it had something to do with the Update animation copy. Once I deleted that extra node it started to work fine. Thank you for the help you are awesome.

I forgot to mention this in my tutorial :wink: