Download

runaway dino spaws

SOLVED Not a bug, just user error.
so I’ve been getting some feedback from players that are having far more dinos/NPCs spawn on my map then they should be.
I’ve been trying to figure out the solution and ended up deleting all my spawns except for one, then setting the min max spawns to 1 and the NPCSpawnEntry to Beach.
All other settings are exact or similar to other NPCZoneManagers on TheIsland (unless the ones on the dev kit version are incorrect. I haven’t run the same test on TheIsland but will later.)

Upon running the game the NPC actor count quickly leaps up to way more then there should be. And doesn’t seem to stop. I got up to 5,000 before I quit (even with min/max set to 1. It doesn’t seem to matter what I set it to.) The game just keeps spawning them, stopping every 100 or so frames to update (which takes a good 2-3 seconds.) Other players have noted the same problem with there being far too many dinos and really bad performance (probably due to the excessive NPC’s.) Players have also noted their Roraima.ark file getting successively large as time goes on, upwards of nearly a gig. It should be more around 20mb-50mb if its like other maps.

I’ve deleted all the associated NPC actors/volumes and started over and still it did not help. Setting the NPCZoneManager’s NPCSpawn entries container to blank does, of course, work and nothing spawns so it does seem to be something to do with those, not a bunch of hidden spawners on a hidden sublevel (checked that.) Only other thing I can think of is maybe there is a world setting I need to fix but nothing looks odd. Also maybe a project setting? But since we don’t have access to the project settings anymore I can’t check that.

Thanks!

Are you sure you’re counting your spawn limits?

If your asking if the NPCZoneVolume and NPCZoneSpawnManagerVolume are linked to the NPCZoneManager then yes. Otherwise I don’t know what limit your talking about. Where is that setting? Or are you talking about a limit set on the server on in game? The issue persists even in the editor when running simulation or PIE.
Here are my settings:d08ae12f300563c281d099a6bc1f346a78edc959.jpeg

I was talking about “only count land/water dinos” option; However, check out these two videos. They may help w/ the setup a bit more.
https://youtube.com/watch?v=85kpz6DEbBE
https://www.youtube.com/watch?v=w3ZNVxtUArg

Yeah I have those parameters set correctly. I’ve had spawners already working perfectly before, this is just a recent issue that I may have messed up after redoing spawns, but I’ll take a look at the videos anyway and see if there might be something I just forgot. Thanks.

Never mind I’m a idiot :slight_smile:
You were correct in your initial comment, snkgeek23.
I had a additional water spawn set up for testing and had the the check limits for land checked instead of water.
Doh.

At least it was a human error and not a bug!

Glad you found the issues :wink: