Download

Rsync IOS remote build issue. MAC to Windows file transfer slow and with wrong permissions

Hello friends,

I´v been fighting with this problem for a long time now. Maybe someone managed to fix it already and can help me.

I´m trying to package my IOS game with a remote mac setup. Followed the very limited official documentations as well as researched the whole internet.

The process works, I get my IPA. But I have a big issue. After this part in the log:

UATHelper: Packaging (iOS): ** BUILD SUCCEEDED **
UATHelper: Packaging (iOS):
UATHelper: Packaging (iOS): Executing /Users/username/UE4/Builds/DESKTOP-/C/Unreal/UE_4.27/Project/MyProject/Intermediate/Build/IOS/MyProject/Shipping/CleanProject.sh
UATHelper: Packaging (iOS): Copying bundled asset… LocalSource: /Users/userName/UE4/Builds/DESKTOP-
/C/Unreal/UE_4.27/Engine/Intermediate/UnzippedFrameworks/GoogleSignIn/GoogleSignIn.framework/Resources/GoogleSignIn.bundle, LocalDest: /Users/serName/UE4/Builds/DESKTOP-
/C/Unreal/UE_4.27/Project/RealRiders2/Intermediate/IOS/FrameworkAssets/GoogleSi
gnIn.bundle
UATHelper: Packaging (iOS): cp: /Users/phil/UE4/Builds/DESKTOP-
/C/Unreal/UE_4.27/Engine/Intermediate/UnzippedFrameworks/GoogleSignIn/GoogleSignIn.framework/Resources/GoogleSignIn.bundle: No such file or directory
UATHelper: Packaging (iOS): Copying bundled asset… LocalSource: /Users/userName/UE4/Builds/DESKTOP-
/C/Unreal/UE_4.27/Engine/Intermediate/UnzippedFrameworks/FirebaseInAppMessaging/FirebaseInAppMessaging.framework/Resources/InAppMessagingDisplayResources.bundle, LocalDest: /Users/userName/UE4/Builds/DESKTOP-/C/Unreal/UE_4.27/Project/ProjectbName/Int
ermediate/IOS/FrameworkAssets/InAppMessagingDisplayResources.bundle
UATHelper: Packaging (iOS): cp: /Users/userName/UE4/Builds/DESKTOP-
****/C/Unreal/UE_4.27/Engine/Intermediate/UnzippedFrameworks/FirebaseInAppMessaging/FirebaseInAppMessaging.framework/Resources/InAppMessagingDisplayResources.bundle: No such file or directory
UATHelper: Packaging (iOS): [8/8] UnrealBuildTool.exe RealRiders2-IOS-Shipping.target
UATHelper: Packaging (iOS): Total time in Local executor: 131.93 seconds
UATHelper: Packaging (iOS): Total execution time: 139.26 seconds
UATHelper: Packaging (iOS): [Remote] Downloading C:\Unreal\UE_4.27\Project\MyProject\Intermediate\Remote\MyProject\IOS\Shipping\Manifest.xml
UATHelper: Packaging (iOS): [Remote] Downloading build products
UATHelper: Packaging (iOS): receiving file list … done
UATHelper: Packaging (iOS): Binaries/IOS/
UATHelper: Packaging (iOS): Binaries/IOS/MyProject-IOS-Shipping
UATHelper: Packaging (iOS): Binaries/IOS/MyProject-IOS-Shipping.dSYM
UATHelper: Packaging (iOS): Binaries/IOS/MyProject-IOS-Shipping.stub

Those last files are being copied from the MAC to Windows with wrong permissions (Ive tried to change the SSH key permissions to every possible option with the same results, so I suspect that´s not it).
The wrong permissions mess the file transfer to a point where it gets totally stuck. Sometimes after a couple hours it manages to copy the files, sometimes (like today) I would wait for 12 hours and is still trying to copy the files. Messing with the files permissions allows Rsync to transfer a couple KB or MB if you are lucky, but that´s about it.

I´ve read a lot of post here and there about Rsync problem from Unix operative systems to Windows describing this exact issue. And I´ve tried to use a manually downloaded Cygwin version and try some of the suggested problems with, again, same results.

As I understand, UE4 is in total control of the use of rsync and I see no options that allow me to change any parameters.

After two weeks of fighting this issue I thought it may be a problem with my OS so I reinstalled the whole thing from scratch and again… Same results.

I literally tried everything. Messing with windows security, messing with SSH key permissions, different UE4/MacOS/xCode versions, tracked the whole internet for solutions…

So plz, is someone has a hint how to make rSync work properly from MAC to Windows I would really appreciate a hint.

THX

Can you try with a different mac? I don’t have any problems with rsync being slow and I use remote build all the time. I’m using Big Sur 11.5.1 & windows 10.

I managed to fix it, looks like my ethernet adapter was not working properly. Thx for the response, helped me pinpoint a little by knowing that the Unreal side of things should be working ok.