Rotation by 90 degrees in a single frame causes motion blur? How to fix and keep motion blur on?


I’ve always had the issue in UE4 of the effect of a motion blur or flicker when setting the rotation of a static mesh in a single frame(Which is required for my building placement game).

Setting motion blur to be off appears to fix this issue, but then motion blur is turned off for everything else which I’d still like to keep. (I tried hiding and unhiding the actor before/after in the same frame but the effect still persists).

Does anyone have a solution to this? It makes things like building snaps and teleportation have annoying visual defects.