Download

Rotating Movement Pauses

Hello,

I’m working on making a set of gears that each rotate at a specific speed perpetually. I’ve been trying to use the rotating movement component, but it frequently stutters and pauses. Is this a bug, or am I going about this the wrong way? I’ve tried using the rotating component both in actor blueprints and as an added component to the static mesh.

ezgif-3-4e31ee6df1

Not much to say without looking at the blueprints… Help us help you.

There’s nothing in the blueprint itself. Just the static mesh and a rotating component with Y rotation. All settings are default other than the rotation speed

:man_shrugging:

I still haven’t been able to fix this problem. I’ve tried getting rid of the rotating component and doing this with blueprints instead, but I’m getting the same results (each gear pauses after doing a full rotation and eventually starts up again). I’ve tried the add relative rotation node as well, same results.

I also tried removing all collision, and that hasn’t had an effect.

Any ideas? I’m pulling my hair out trying to figure out why this seemingly simple thing won’t work

That’s weird… this should work just fine. Have you tried printing the local rotation after the AddLocalRotation node?

It prints out the rotation speed repeatedly (Something like -0.067) It keeps printing the same number even when the gear is paused.

I’m using version 4.26.2 and starting to worry this may be a bug

I fixed it! Sort of! I opened my project at my work PC, and the problem doesn’t exist. It must be a hardware issue. Does anybody know if this is a known bug or if there’s a workaround? My home PC is the main one I work on and I’d like to get this working there as well.