Root Motion?!

Man, this is really giving me a head-ache.

I wonder if anyone can help me out?

I’ve set up AnimMontages, I’ve set “Root Motion” to true in my animations, “Root Motion from Everything” in my Anim BP and exported my anim for 3DS Max (CAT). It animated fine but does Root Motion work? NOPE.

I have no idea what I’m doing wrong. My animMontage runs fine but the capsule won’t move to the correct location AND the character snaps back after the animmontage has played.

I keep reading about needing a root bone but in my skeleton hierarchy of my character, the Root is there and it’s sitting there all happy.

I have no idea what I’ve done wrong. I don’t know if my animation actually has a root (Due to the fact I used Bruno Brito’s CAT template to export it) but when I import it, the Root stays at 0, 0, 0 but I have a white line going to my characters hips moving.

Have I done something wrong as is there anyway to get the Root Motion working (As I need it for my character’s attacking).

Please help someone :<

I’m not familiar with the 3DS Max (Cat) system. However one thing that jumps out at me compared to the root motion documentation are the extra bones left behind that may be constricting the capsule verses how the rig looks here:

For root motion, the root bone needs to basically follow the XY on the pelvis and stay on the floor, so no animation on Z. So, it sound like in your animation your root is always sitting on 0,0,0, which will give you no motion at all.

You should be able to just rig up the root bone to follow and then re-export and should be able to get working root motion. Either that or just put the same animation that’s on the pelvis, also on the root bone without affecting Z of course. Depending on the rig it can either just be done or you may have to constrain things.

I did do a CAT rig recently for the blue guy that has this all set up, if you want to check it out. The way I set it up is through transform expose and wire parameters. Don’t know if you dealt with that stuff before or not, but it’s a fairly simple setup.

@Obihb - You fixed all my problems; You da man! :smiley:

How did you fix this issue? I have the same problem with my Biped in 3ds max and I don’t know how to move the bipeds root bone.

Technically the Bip001 is the root of the Biped, but that is not a game friendly setup. Typically you want the root to stick to the floor and animating Biped you always use Bip001 to move the pelvis, in which case it will go up and down all over the place. Because of this, you shouldn’t really use the Biped directly as your skeleton. It’s not friendly to rig modification and you generally would want more control over your game rig than what Biped allows. It’s just much easier to use a custom skeleton, and you can drive it directly with Biped, and still get the benefits of using mocap easily, or transferring animations easily, but have the freedom of simple bones to make the in game skeleton.

I had to reply because I found a better solution. Spent a couple days pulling my hair out! You CAN animate in the Z axis, the root bone just can’t go below the floor plane at any point, or all animation is destroyed (without telling you).

I solved this in Maya by hooking up a conditional node that sets the root Z transition to 0 if it dips below the floor. Otherwise, it follows the hips upwards. This worked great for ledge climbing. :slight_smile:

I have used rubber band mode to move my bip001 to the floor, and all works well. Did that so that i won’t need to have an extra bone before Bip001. The problem i am havin is that if i export fbx from UE to max and load that on my biped, i get no root motion whatsoever… even if i check Map root motion in the fbx’s export dialogue… Any ideas anyone? :confused: