Root Motion Z-Axis Problem/Bug

Hello, I have a problem with using root motion. Maybe I’m missing a point, maybe it’s a bug, I don’t know. Root motion option does not apply on z-axis in both animation editor and in-game. To be more clear and specific let me explain with 2 examples, I got a walking and a climbing animations. Walking animation works perfect because it only interests x-y axis.

At first frame:

After some frames:

As you can see, it’s in the same place as it should be and expected. I’ve already applied this walking anim to my locomotion anim blueprint, works perfectly.

But for climbing animation:
At first frame:

At last frame:

Animation location changed in spite of I turned root motion on. I’ve searched the form and answerhub, most of the people faced with z-axis - root motion problems, but they solved their problem by setting their character’s movement mode to flying, I already tried it and didn’t work for me. Also in my opinion, this problem is unrelevant with movement component.

If you want to get animations to test them, I’m using mixamo animations, as you know they’re free for now, you can download same animations.

Thanks for your help, I hope I’m missing some point and it’s not a bug, otherwise we’re gonna lose significant time in our job.

I think I found the problem, that would help anyone who uses Mixamo animation that related with z-axis. Climbing animation does not change root bone’s location but pelvis. That’s why enabling root motion does not effect z-axis.

I have a same problem, how can we fix this ?