Download

Root motion won't turn off?

Hello, while working with animations I’m noticing the root motions seems to be stuck on.
5f4724dd2c851b3246a0092b2fd39d58.gif

Whether ‘Enable Root Motion’ is on or off, or using any combination of ‘Root Motion Root Lock’, it always results in the above image.
The problem is that makes the mesh walk out it’s root, so the camera+collider stay in place while the mesh walks away.

How can I properly shut off root motion so the animation sits in place?

Thanks.

Hey,

This is a shot in the dark, but maybe the movement is baked into the characters joints rather than into the root? If the root joints stays at 0 during the animation while everything else moves forward, there’s no way to disable the forward motion in unreal.

I think that may be the problem yeah.

I’m coming from unity where you can pretty much do anything with the animations (flip em, offset em, blend em together, lots of root motion controls, play from anywhere, etc).
Hopefully Unreal5 gets a few more usability features :smiley: (lovin unreal4 so far)

In your animated gif, that is what happens when root motion is NOT functioning. When root motion IS functioning it will appear in Persona’s preview as though the animation is happening in place (with the actual motion being driven be the character’s capsule in game so that it does not snap back to the beginning.) -Be sure root motion is selected in the AnimSequence and “root motion from everything” is selected in the AnimBlueprint

Enable the skeleton view and you could actually confirm this.
By the way, there is plenty of animation control in UE4 too… blending anims together, root motion, play from anywhere, flip em, offset them…all of this is possible in UE4 except for mirroring - why do we not have this yet Epic?!!