Download

Root Motion weird behavior

Hello there,

I am relatively new to Unreal, and definitely a complete newbie when it comes to Blender. I’ve been playing around with Mixamo animations for past few days, trying to add a Root Bone to them, consuming lots of videos and possible solutions on daily basis. I prefer to learn how things actually work instead of using addons/plugins to get something to work, and when I finally got most of it to work, I’ve experienced an issue that no matter what I do I can’t find a workaround for.

I have a skeleton which was created from Mixamo’s T-Pose base, whose Armature was renamed to Root in Blender. It was then exported to FBX and imported to UE4.
After skeleton was done, I’ve tried importing animations into blender, adding Root Bones to them in Blender, and then importing that .FBX to UE4. Both of these things were done with the help of this tutorial:

The only step that I had to skip in this tutorial (and I’m not sure how important it is regarding the issue), is the 20:30 mark, “Fix BHV Axis…” because that plugin does not exist anymore.

In preview everything looks smooth, animation is positioned correctly, there are no visible issues, however, as soon as I enable Root Motion, my mesh rotates 90 degrees and faces the Z axis, with its back on the ground and the Roll animation still playing.

Here are some screenshots showing my setup in both Blender and UE4:




Any help would be greatly appreciated.

For some people who experienced similiar issue is how I’ve managed to fix this:

In blender, DO NOT rename your “Armature” to anything else. Some tutorials and forums said it is necessary because of import error, however it seems it works fine.

2 Likes

This should have nothing to do with naming conventions (unless you are mapping animations inside the engine or elsewhere) this has everything to do I suspect of skipping to correct the orientation axis.

Never use Mixamo rigs out of the box, also never import as they are, and finally don’t bother mapping animations inside the engine directly. Create your own rig in blender with correct compatble axis especially on the root bone and X axis ALWAYS facing forward and Z axis always up as is the case in UE. And then map the animations from Mixamo rigs onto your own rig and then export this rig into UE4.

Everything else is a waste of time and asking for trouble.

That is a fantastic tip, thanks a lot William. I’ve been going through tons of troubles with Mixamo animations, as soon as I fix one issue, another ones come up right after. I’ve managed to fix almost everything, however, now I’ve came across something so weird that I can’t even find a similiar issue on google after an etnire day of searching. I guess I have to study Blender a little bit more to get things working as I’d like 'em to.