Root motion shows in animation blueprint preview, but after compile, gets reset to "montage only", and won't work during playback

I created a dive roll animation and wired it into my animation blueprint. After setting Root Motion Mode to “Root Motion From Everything” it works fine in the animation preview window in the upper left. Unfortunately, after compiling, the Root Motion Mode is always set back to “Root Motion From Montages Only”. In addition to this, during playback, the capsule doesn’t move with the character, and exhibits the “snapping back” behavior of an animation without root motion.
It’s worth mentioning that I exported the animation from Blender, and the skeleton’s “Root” is the automated “armature” root that blender spits out. However, I was able to animate that root by creating animation on the Object level in blender. So as far as the Persona preview window, everything works fine, it’s just in the animation blueprint and in the actual gameplay that it breaks.

Ok, It seems that I had been changing the settings in the “Edit Preview” window instead of the “Edit Defaults” window. That fixed the compiling problem. Unfortunately, I still can’t get the dive roll to translate properly. It just dive rolls in place, without any translation at all.

I’ve noticed that clicking on “process root motion” doesn’t actually move the character in space, and that clicking on a Root Motion Lock of “zero” makes the character disappear. I know those were things I was supposed to look for, but I don’t actually know what they mean, any assistance would be appreciated.

I was able to find an answer. It all had to do with the scale of my scene. Since I had chosen default “Blender” units, any armature transformations were scaled down to .01 of their normal size. To fix this, I set the scene to metric, and multiplied all armature level translations by 100. It looks ugly as sin until you apply root motion, where it actually works great, even with “Process Root Motion” on.