Download

Root Motion Not Working

So I have a very weird and complicated issue here. I’m currently using UE 4.22 and Blender 2.8 to build my game. A while back, I started my project over using 4.22 and switched over to 2.8 because the old project had too much clutter. In the old version, I had animations with root motion working correctly. However, trying it out with these new tools is causing some issues. I’m using the same approach I used before to animate, the skeletons have the correct hierarchy with Root as the main parent bone, and I position them using the LocRot keyframe channel.

In the engine, root motion is not working. Without root motion enabled in the animation viewer, the mesh is too small to even see (but the scale of the mesh itself imports into the engine just fine … -.-). Enabling Root Motion here fixes the scale issue and correctly plays the animation. Going into the AnimBP and setting it to Root Motion from Everything, however, renders the character unable to walk around. It can still jump, fall, and if in the character blueprint, under Character Movement, the option Allow Physics Rotation During Anim Root Motion is checked, the character is able to pivot around in place. This issue only occurs when Root Motion is enabled in both the AnimBP or the ANimation Sequence. If either or both have RM disabled, you can walk around again.

Testing animations with RM in either of these cases does not work. I’m not going to recount the full list of things I’ve tried to fix this, as the list is really quite extensive and I honestly don’t remember them all. I will try anything that is suggested here, because at this point I’m out of ideas and I kinda have to throw up my hands. I will add my export settings for Blender and my import settings for Unreal. If there’s more information needed, please let me know and I’ll add it in.

Root Motion from Everything being on is how I got RM working in the old version of the project. I haven’t tested it with Montages only because I don’t have any made to test it out with. Didn’t need them last time. Also, like I said, turning off RM in the animations themselves causes the model to shrink, even though the scale is not different than the skeletal mesh itself. This problem existed before I moved into the new project file and continues to baffle me.

I made several changes to the actual meshes, mostly cosmetic. The skeleton is different, but it follows the same setup as the old ones, and the hierarchy is correctly set up. I did try converting a test animation with using RM just to see if it was working into a Montage, probably did it wrong because like I said, didn’t need montages for this to work before. Viewing it in the animation sequencer doesn’t show the movement, and setting it up to play and use montages didn’t get any movement either.

I’m wondering if I’m not animating RM correctly in Blender 2.8. In the animations I made to test it, the Root bone was moved along with the rest of the skeleton, and the only change I can think to make during export is to go under the Armatures node and change the Armature FBXNode Type from Null to Root. I guess it’s worth mentioning that I still use FBX for my models and animations.

Is there anything else I can help clarify?